Error when attempting to flash

I have installed, uninstalled, and reinstalled ALL OF THE LATEST versions and keep getting this error. Raspberry pi4 4g Brand new.

Something went wrong. If it is a compressed image, please check that the archive is not corrupted.


Please help with this as I am losing my mind!!


1 Like

What format image are you trying to flash? If it is a zip/archive, can you try first expanding it with the operating system supplied tools to see if the archive is actually valid?

1 Like

unzipped octoprint file. The newest version of both Etcher and Octoprint. I followed the directions to a tee.

1 Like

I’ve downloaded, unzipped and flashed the image with the latest Etcher on macOS. Have you tried all the obvious things like starting Etcher as administrator?

1 Like

I have. I’ve confirmed current versions, and unzipped using RAR. This is driving me mad since I don’t know where the problem is. Is it Octoprint or Etcher?

1 Like

The issue is probably between Etcher and Windows actually, possibly the USB hardware. Do you have another system you can try this on, maybe with a different USB drive?

1 Like

Seriously??? Is it common to have any issues with this that I don’t have with any other program? And, no I don’t have another system. The system recognizes the flash drive and I can read off of it. This is really pissing me off. :frowning:

1 Like

like I’ve said, I have uninstalled and reinstalled BOTH programs at least 3 times.

1 Like

I think I’ve determined that it’s Octoprint. They put up a new version just today and I think that there are issues with it. Thanks for your help. If it’s NOT them, I’ll be back. :slight_smile:

1 Like

Come back anyway.

On Win-10, I have had problems depending on what interface and/or adapter I use.

If you have a working native SD card slot on your system, that usually works, at least it works for me.

Adapters, shims, USB dongles, multi-readers, etc., may or may not work. Note that I have not tried any of this on any flavor of Linux.

My suspicion is that the SD card manufacturer may not be fully implementing the SD card interface standard properly.

The SD standard says that SD cards must implement both the “SD” interface AND a USB interface so that USB to SD card shim adapters can be used.

I suspect that at least some of the cheaper brands short-change the USB interface testing, or haven’t updated their interface software since 512 meg devices were new.


I never, absolutely never*, have problems using a native SD card slot on my computer, but USB based solutions are almost always a crap-shoot, particularly with cheaper cards.

* Note that off-brand, bargain-bin SD cards are almost certain to fail. If not now, later. Or you will get flakey intermittent problems that are The Devil’s Own Mother to track down.

Spend a few extra centavos and get the good stuff. It will amply repay you in lowered blood pressure and angst levels.