Balena Etcher is throwing error

hi guys,
i came to know about balena etcher through POP OS installation instruction. So i installed etcher and flashed POP OS on my USB drive successfully and booted to POP successfully and after that tried Ubuntu 18.04 LTS and booted to it successfully and then tried to flash POP OS 19 but from this on etcher is throwing an error and rendering my pen drive unusable to use my pen drive i have to format it through EaseUS partition manager , now every time i am getting error through etcher but Rufus is working fine.
I tried latest etcher version at first which flashed my pen drive successfully 2-3 times before throwing errors and i googled and installed etcher 1.2.1 and getting same error messages.
Attaching screenshots below.!
New users can upload only one file…LOL

I think your problem might be related to the one described in one of the github issues.

As it mentioned in the ticket, we are working on updating the Electron (and node) versions used by Etcher to mitigate the problem.
One of our maintainers mentioned that pre-formatting the drive before flashing might help.
I will also appreciate if you verify that you can run diskpart as an administrator on your machine and perform list disk command.

i did pre-format before flashing and ran list disk command(as an admin) then followed by select, clean,make primary,active till format but still i am getting this error.
i tried uninstalling and installing etcher but end result is the same.

Thanks for the info. We took a note and will post an update once we make progress. Meanwhile, feel free to follow the github issue Roman linked to.