Please!! I need help bad here!!!

Okay, this is definitely not the first time I’ve had problems with this tool for flashing. I’ve downloaded it, unzipped it, and tried to execute it over and over and over and over and over again, yet nothing happens or it says permission denied which makes no sense as the permissions are set to let it run as an executable program.
I’ve been able to use balena before but I’ve also had awful problems just getting the damn thing to even open.

Could someone PLEASE give me some simple instructions that actually work on how to download and utilize balena etcher electron on a RHEL 8.2 OS running on a Lenovo Thinkpad T450??? Please as this is extremely frustrating and I’m about to smash my damn laptop with a baseball bat at the moment as this isn’t the first time having trouble with this. This shouldn’t be this difficult everytiume i want to flash a usb drive.


This is all I get out of my system when putting the command ./balenaEtcher-1.5.120-x64.AppImage
[rubuntznu@localhost Downloads]$ ./balenaEtcher-1.5.120-x64.AppImage
bash: ./balenaEtcher-1.5.120-x64.AppImage: Operation not permitted

Why does it do this?? I’ve downloaded the appropriate ISO.
I’ve properly unzipped the file giving me the AppImage
I’ve tried running it several different ways from Sunday.

What in the hell gives here!!!
It has worked before performing these EXACT SAME steps listed above. Why is this not working? Why am I having such an awful time trying to utilize this tool? Maybe I shoulkd find another option here as this is absolutely ridiculous since this is not the first time this has happened with this tool. Again, any help would be GREATLY appreciated…

Sorry to hear that @sgearhart we are working on discovering the issue you are getting.

Meanwhile could you please try to use Etcher with the previous version and let us know if that works for you?

Thank you!

Hi, sorry to hear you’re having trouble with the AppImage.

Did you make the AppImage executable? chmod +x ./balenaEtcher-1.5.120-x64.AppImage

@sgearhart – Did you try the previous recommendation?

chmod +x ./balenaEtcher-1.5.120-x64.AppImage

Then try running it again.