Device won't boot with custom config and cmdline

Hi All,
I want to delete an application. First i moved devices to another app.
but now i get the message: Application not found.

The problem i run into is that i moved my code from a repo to another repo and i want to overwrite it.
but resin gives the message this is not possible and iam not sure how to fix this only to remove the app and add it again so its empty.

hint: Updates were rejected because the remote contains work that you do
hint: not have locally. This is usually caused by another repository pushing
hint: to the same ref. You may want to first integrate the remote changes
hint: (e.g., ‘git pull …’) before pushing again.
hint: See the ‘Note about fast-forwards’ in ‘git push --help’ for details.

Ah i found i can force update with : git push resin master -f


Seems like you figured it out, is there anything else you need help with?

Well i have some new RPi3 devices i want to connect to my application.
Its a CM3 based device.
I did download the firmware flashed it and added the extra config like on the other devices i have.
I have connected them via ethernet.
But they will not show up as new device in the resin portal.
Is there anything i can do about it?

@RDB, what CM3 compute module is it, some of them require a custom DT-blob in order to correctly enable all the hardware, like ethernet and wifi chips. I think the best thing to do would be to download a .dev build of resinOS and then attach a serial console cable to the board. That will give you console access to the device and you can poke around to see if the network interfaces are being brought up correctly.

I indeed added a blob. And the cellular file.
This time i didnt wire the config.txt and cmdline.txt.
Now resin is booting and the portal is seeing a new device.
I will try to add the custom config and cmdline later.

Edit. When adding the custom cmdline and config. it won’t boot correctly.
I have to check that again.

I have compared the 2 cmdline.txt files.
From the initial device that is running fine and the new one.

dwc_otg.lpm_enable=0 console=null root=/dev/mmcblk0p2 rootfstype=ext4 rootwait vt.global_cursor_default=0

dwc_otg.lpm_enable=0 console=null root=/dev/mmcblk0p3 rootfstype=ext4 rootwait vt.global_cursor_default=0

As you can see only the /dev/mmcblk0p3 is different.
Can you tell me why this is? What i do know is that the new version runs resin: Resin OS 2.12.5+rev1 (prod)
And the previous box is running: Resin OS 2.12.3+rev1 (prod)

Hi, the root= device starts at ...p2 (the second partition) for a new device. ...p3 is the secondary root partition, and when doing a host OS update, then it will be switched between p2 and p3 (and on the next update it will be switched again, and so on).

Can you explain what is the “initial device” and “new device”? Rereading this thread it is not totally clear of what are you doing.

Also, cmdline.txt modifications are not supported on resin at the moment, as host OS updates will overwrite changes to that file.

Ahh clear to me that explained why the new devices wouldn’t boot with the cmdline.txt i put on the CM3.
The initial device has had a host os update so it was pointing to the 3rd partition. When i added a new devices and added the cmdline to this device it was pointing to the 3rd partition insted of to the 2nd.
From now i won’t touch this cmdline.txt for new devices. I tried it with a coulple already and now everything seems to run fine :slight_smile:

1 Like