Device not updating after push

I have been having some trouble updating my code in the repo on Resin.

I first tried manually copying the multicontainer example provided by the getting-started page, but it didn’t work, it kept trying to find a Dockerfile in the root directory.

Then I clone the exact same project, and added resin remote from within it, then the push succeeded.

When I tried to go back to the manually updated folder it gave me some errors like I have to pull first, but the pull failed due to unrelated stories and even fixing that, gave me a fail in push. So eventually what I did was erase the .git folder, run git init again, added the resin remote, move all manual content to a different branch (for testing purposes), then pulling from resin and merging with previously saved branch. I fixed some conflicts and run git push resin master, the build run ok, and it showed that it pushed the changes to resin master, however, the changes are not being downloaded by my device.

i’m using an Intel NUC with Resin OS 2.12.0+rev1 (dev)

I attach an image in which you will appreciate the difference in commits.

Thanks for any help.

If your source code has changed significantly from the code you last pushed to our git server then the push will fail and you will need to use git push resin master --force to force the git server to accept the push.

@lucianbuzzo yes and thanks, I have already passed that problem thg.

The problem I have right now is that even with the build and push passing, and even seeing that new release in the releases section, but the Device itself won’t update to the lates commit.

I attach an image with both views releases and Devices list so you can appreciate it is currently behind.


Hi @felixbanguera
Looking at your screenshots I can see you are using resinOS v2.12.0 which has some known issues with pulling updates. Updating to the latest OS version should fix this issue for you.

ok @lucianbuzzo , thanks, will do and let you know.

Thanks for the help in advance.

Updating to the latest OS version worked for me. Thanks @lucianbuzzo

1 Like