Config.txt overwritten and dt-blob.bin ignored

I’m currently trying to set up a Compute Module on a custom PCB and am having some trouble with the config.txt / dt-blob.bin setup. I have a config.txt and dt-blob.bin that has worked perfectly in the raspbian OS, but am having troubles using it on resinOS.

I’ve tried a few ways of doing the config.txt:

  1. Creating RESIN_HOST_CONFIG_ entries through the dashboard. This method works, and I’m able to enable i2c as I wish and communicate over it. The problem is that it has to be enabled through a dtoverlay=, and so does the uart’s on my device, so I can’t user the RESIN_HOST_CONFIG_ if I want to use more than one interface at a time - which is what I need.

  2. Mounting the eMMC of the Compute Module (On MacOS and Windows) and adding/replacing the config.txt that is located on the /resin-boot partition that shows up when this is done. When this is done, the config.txt that I load is replaced again by the one that I’m assuming the RESIN_HOST_CONFIG defines. I tested by setting the gpu_mem value and could see that that’s what was replacing it, leaving a config.txt with just gpu_mem=124 on the mounted partition.

  3. Editing the files located on both /resin-boot or /mnt/boot/ through the Host SSH session on the dashboard, adding the lines by copying them from the working config.txt from raspbian. The /resin-boot/config.txt seems to be ignored, the /mnt/boot/config.txt get’s overwritten as in 2.

When booting up the device, I notice that in the logs, the service starts, but then after a little time the text below is printed to the logs and the device reboots (At which point I guess the config.txt is cleared):
28.02.18 08:08:42 (+0200) Applying boot config: {}
28.02.18 08:08:42 (+0200) Applied boot config: {}

With regard to the dt-blob.bin, I’ve tried copying it at the same time as the config.txt in 2. above, but it doesn’t seem to be working as I can see that the pin defaults that I set in the file aren’t applied after boot.

Any help in this regard would be greatly appreciated.


Ok, I see through some more reading that I’m able to define multiple dtparams/dtoverlays using:


So that means I can fully define my config.txt through the web interface.

What remains now is the dt-blob.bin being ignored.