Compute Module doesnt appear in Etcher

I’ve tried to flash my BalenaFin with Ether on Windows, Mac, and Linux, but I can’t get the Compute Module to appear as a Target.

balenaFin - Docs

I have followed all the instructions to make it appear but nothing.

None of the pc detects the board or as USB.
I already tried without the barrel jack and with the barrel jack

I also used a lot of different cables already, but it doesn’t work either

Hi @altaga ,

Welcome to our forums! You seem to have a v1.0 balenaFin, can you confirm you’re following this process just to be sure:

  • Disconnect every cable from the balenaFin
  • Connect the micro USB cable
  • Connect the barrel jack

If the above doesn’t work, it’s usually one of three problems:

1- The compute module is not properly seated on the SoDIMM connector. This is sometimes difficult to spot, so make sure both clips are properly attached.
2- The micro USB cable is faulty. If you purchased a developer kit, try with the included cable. Otherwise, could you please try with a different cable?
3- Not using a CM3+ Lite. This is a less likely scenario, but please make sure you’re using a “Lite” version of the Compute Module 3. In the lite version, the chip highlighted below should be missing:

Let us know if you still have any questions.

1 Like

Yes, I already did this process, I already checked everything, tried all of the above mentioned and nothing.

Hello @altaga first of all apologizes to hear that you are struggling flashing the fin!

Could you please share a picture of the other side of your fin with the compute module?

On the other hand, could you also please share how are you connecting the microUSB to your computer? directly? or to an adapter?


Hello @altaga ,

If you still have issues flashing the compute module, you can send us an email at to process a return. If you do so, please provide the order number for when you purchased it.