USB Cable Issue

Hello I hope this finds you well. I have tried numerous USB data/power cables and still can not get the board to show up in Etcher as available storage. I know the website says to make sure you have a good quality cable and unfortunately I didn’t order the developer kit that includes one. Could you please recommend a good known cable I can order that you know will work?

Thank you in advance!

Hi, probably you are not running into a USB cable issue. Could be the permissions you are running Etcher with. What OS version are you using? Are you running it with administrator permissions?

As a side note - for testing purposes you may try running rpiboot first with admin permission and then Etcher with non-admin ones as well - Etcher includes the same mechanism, but it requires admin permissions.

Also if you are using a Fin 1.0 version, and not 1.1, make sure the device is powered as well.

Hi there, thanks for the reply. My current OS is Mojave 10.14.4 and i’m running BelenaEtcher 1.5.79. The board is version 1.1.0.

I right click and press open to start it which usually runs in Administrator mode but i’m still not seeing the Target available. This is one of the cables i’m using but i’ve tried numerous others.

Any other insights?

As for the testing purposes with usbboot, doesn’t this have to be on the image to be downloaded to the board or do you mean install usbboot onto my Mac?

Thanks again for the help!!

If you run sudo /Applications/ and then plug in the board, what do you see? I think the most likely cause here is that etcher is not running with root privileges, and in that case it cannot flash the fin in usbboot mode.

Thank you kindly for the quick response. I ran the command here is what I get
(node:29353) Electron: Loading non context-aware native modules in the renderer process is deprecated and will stop working at some point in the future, please see for more information
ready-to-show: 3267.408ms

Board lights up getting power etc but still not showing up as available target still…

Any other ideas?

For what it’s worth, I seem to be experiencing the exact same issue with my balenaFin 1.1 (32GB).

Also running OSX 10.14 with Balena Etcher 1.5.80. I’ve used three different cables all with the same result.

I’ve also plugged it directly into my Pi4 (Raspian) and do not see any relevant entries in /dev/ nor log messages via dmesg.

Happy to perform any additional tests as needed.


Hi folks.

I’ve just tested this with my mac (running macOS 10.15.4) and etcher 1.5.80 and flashed my Fin 1.1 fine. I realise that I’m using a newer version of macOS to you folks however. I know it’s a drastic request, but is there any chance of upgrading to 10.15 to see if that fixes the issue? The other suggestion would be to try an older version of etcher pre any changes to support macOS 10.15 - looking at the change log that’d be around about v1.5.60.

The other feedback we got from our Fin engineers is to make sure that the compute module is installed correctly and to post a picture of the LEDs when the Fin is connected to the computer with Etcher open.


I just updated to latest version of Mac OSX and latest etcher, tried the sudo /Applications/ command and opening normally and still same issue… I do not have the compute module just the board.

Any other insights??

Thanks in advance!

Wait, you’re trying to flash the Fin without a compute module installed? This definitely won’t work. The CM is used to turn the on-board eMMC into a linux USB mass storage gadget.

Ahh okay!! I didn’t realize that the compute module was a requirement for the board to work, apologies… Okay well, I guess that solves it, I need to get a compute module…

So just to clarify if you want to run any OS on this board you require a compute module?

Yes, the Fin is designed as a carrier board for the compute module. Without the compute module the board is basically just a pile of peripherals with no brain.

1 Like