cannot detect device after flashing fail


Following the step of balenaFin Getting Started, I have some problems
Here is my steps,

  1. select balenaOS and download the image
  2. connect a USB to mico-USB cable between win10 laptop and balenaFin_V1.1’s PRG port
  3. Open balenaEtcher 1.5.59 and select the image downloaded previously
  4. cannot select target because of it need CM3 driver, so download and install driver on
  5. start flashing, it fail when flashing 21%
  6. retry flashing, still failed, it shows unknown error
  7. after second failed, system can not detect balenaFin device anymore

I am a new developer for embedded system. Could you help me for this?
Thank you.



Can you please have a look at the troubleshooting to see if there is anything useful?
Also even now, your system can’t detect the Fin when it’s plugged?

Hi there, I have a few questions that will help me get a better picture of where the root cause of the issue might be.

  • Did you purchase the balenaFin Developer Kit? If you didn’t , what Compute Module, USB cable and PSU are you using?
  • When you retry flashing, is the balenaFin mounted as a storage device?
  • If you plug the balenaFin to the power supply, what LEDs do you see turned on?


Hi Nico

Thanks for your reply.
I purchased balenaFin V1.1 Developer Kit on official website.
When plugging to power supply, 3V3 and 5V of Status LED are turned on, RGB LED shows weak red.
I do not get the point about question 2. Could you explain more about it?


I found out the reason for detecting no device. I do not install the CM3 properly.
Now I can detect the device by balenaEtcher, but flashing still fail.
I download the balena.img on
Selecting Fin, I have tried image both Production and Development.
What may I have overlooked?


My colleague is investigating the problem. Meanwhile, can you try to debug etcher when it fails flashing? You can see logs in Devtools (Ctrl+Shift+I) console tab.

Hi balena team

It is success for flashing image. Under win10, I execute Etcher as system administrator, and it work.
I am not sure it is the root cause because after flashing successful, now I cannot duplicate fail case anymore. Even thought executing without as administrator, it still can flashing successful.
Do you have any comments?


That is indeed strange! I am trying to reproduce this on a windows 10 machine, but it will be tricky as I might need a fresh OS install to mimic your experience of etcher requiring admin privileges only during the first flash. Thanks for reporting this!

Hi @marktu555,

Glad to hear the issue is solved. Since it was a pretty strange issue, if you experience it again in the future, it would be great if you could share the logs as my colleague mentioned earlier. That way we will have more tools to debug and see if we can find the root cause.