Compute Module CM3 & Resin

Hey guys,

Does anyone already have tried installing ResinOS on the Raspberry PI Compute Module CM3?

Any special things to keep in mind?

I’m gonna try next week to do this myself, as I am currently developing my own PCB with a slot to fit the CM3. I’m building this to do some RS232 & networking stuff. Any help, tips or previous experience would be greatly appreciated, as it might save me a lot of time :slight_smile:



Hey, I heard from our device team that the Compute Module 3 should be available on the latest beta version, that is on our staging or experimental site at (that is resinOS v2.0.0-beta13.rev3 for the Raspberry Pi 3).

It’s in testing phase, would be great to hear any feedback! :slight_smile: The v2.0.0 production release is not too far, and from then it will be available on the regular site too.

It looks like there are other people experimenting with the Compute Module as well ( @simonkemper and @curcuz for sure), here’s some more discussion as well.

Ok thanks for the reply! That will be my starting point then, trying out ResinOS 2.0. I’ll keep you updated!

1 Like

Hey guys, quick update:

I just tried ResinOS 2.0 on the CM3 and it seems to work out of the box! It’s currently installing the application container running on my other Raspi3’s but everything seems to be going very smooth :slight_smile:

Respect to Resin Team :ok_hand:

Hey, cheers! I’m guessing you’ve used the 2.0 release candidate that is in the dashboard just recently? The proper release is coming soon, in the meantime any feedback is appreciated, as it was prepared for last weekend’s hackathon and we are still testing things. :mag:

Yes I used that image indeed.

So, all my (python) applications seem to be running just fine. The only thing ‘out of the ordinary’ compared to a regular RPi3 is some error msgs I get in the log-console on the dashboard. They don’t seem to affect my code running properly, but maybe it helps you? Do you know where the errors are coming from?

Regular RPi3:



Thanks for the heads up!
I have a guess - if you were running the normal Raspberry Pi 3 on the same resinOS version, you’d see the same error, it looks more like a resinOS 1.x <-> 2.x thing (maybe, just maybe that I think we are not running the audio module by default anymore, an issue that was discussed before). Is your code using audio at all? Or I wonder why ALSA is started there?

Aaah thats probably it. No I don’t use audio in my code…