Balena Etcher won't detect my Balena Fin, on a different computer it does

I’m using NixOS and I’d like to flash an image to my BalenaFin. I tested Balena Etcher on a Mac computer and it detected the target and I successfully flashed BalenaOS to it.

The way NixOS runs appimages is somewhat unique, and I suspect this is a distro specific issue which I don’t expect the community here to help me solve (NixOS runs such appimages in an chroot environment).

The issue is that I do see the compute module when I run lsusb:

$ lsusb | grep BCM
Bus 001 Device 047: ID 0a5c:2764 Broadcom Corp. BCM2710 Boot

But in contrast I don’t see any new device when I run:

$ df -h
Filesystem      Size  Used Avail Use% Mounted on
devtmpfs        792M     0  792M   0% /dev
tmpfs           7.8G   80M  7.7G   2% /dev/shm
tmpfs           3.9G   12M  3.9G   1% /run
tmpfs           7.8G  552K  7.8G   1% /run/wrappers
/dev/nvme0n1p3  938G  483G  452G  52% /
tmpfs           7.8G  104K  7.8G   1% /tmp
/dev/nvme0n1p1  511M  160M  352M  32% /boot
tmpfs           1.6G  304K  1.6G   1% /run/user/1000

I also tried launching Balena etcher with sudo and it didn’t detect it either.

Can I conclude that there’s something wrong with my Linux PC’s hardware not detecting the device? Or is everything OK?

Ideally there was some support for a non gui app to flash images to the devices. I noticed there was in the past an etcher cli, but it’s deprecated now. Can I still use it with the latest Balena Fin hardware?

If it’s considered that BalenaFin is detected properly I’ll try to get help at NixOS’ forums.

I managed to install etcher-cli outside a chroot environment (unlike the not deprecated Balena Etcher) and I encountered the following error:

x No available drives were detected, plug one in!

So I think that’s there is something wrong if I don’t see a new device in df -h