Can't format usb after flashing it.

Hi! I’m new here.
I created a usb with Puppy linux, Kingston 2.0 DataTraveler 16GB, and now I wanted to flash it with another distro using Etcher but I can’t. I keeps working as a installer for that distro, but it is not recognized by my system properly if I try to format it.
When I plug it Windows says “E:/ directory nave is invalid” but in Spanish, maybe my translation isa not okay. I tried using diskpart.exe and the Disk Administration tool but I simplt can’t format it, the tools recognized it but they can’t finish the cleaning or format.
Thanks!

Edit: * clearified that I tried to use etcher to flash it again.

Hi @martb did you try to re-flash another image on the same USB stick using Etcher? You should be able to do that without formatting the drive first. If you do want to format your drive please have a look at our blog post where we have some advanced instructions on how you can do it: Etcher killed my USB stick … or did it? . Hope this helps.

Thanks, man!
I tried those things as said before.
But now I downloaded Rufus and it seems to be creating a drive to install, in this time, Windows. I’ll tell you what happens. It seems to be creating the drive with no interruptions.