SanDisk USB stick unresponsive

I made a Linux boot disk out of a USB stick. Now I dont need it anymore and tried to format it via W10. The bootdrive was splitt into 3 partitions and only one could be formatted. Now the USB is unresponive, Rufus cant access it, diskpart neither, it doesnt show up as a drive, but disk management shows it is online with a healthy partition. Any action on the drive like assigning a drive letter or else results in a “The system cannot find the file specified” (why file and not drive is a question in itself), a “drive is not ready” with HDDLLF 4.40 or similar errors.
Any suggestions to make this a come alive again?

Thanks for getting in touch, @kungfu. Let’s see if we can get that drive back in working order.

From the context clues of your original message, looks like you’ve tried a few Windows and MacOS-type solutions. Check out this blog post: Etcher killed my USB stick … or did it?

There’s a Linux-type option near the bottom that might work. Please give that a try if you can and let us know if it helps.

Hello Andrew,
I would like to try it, but the USB stick that had linux on it is the dead one. And I rather not create another USB with Linux on it to fix the first one. Then I might end up with two unresponsive USB drives. Do you have another suggestion?

Hi, kungfu, did you try the instructions under “using windows”?

You should not need another USB stick, just follow the instructions for windows using diskpart.

I think Andrew was just suggesting you try to format on a Linux machine, because you had already tried diskpart, but have you tried following the instructions on that page?

But if you do have a linux machine, and the windows instructions don’t work, I would try it on the linux machine as well.

If neither of those work, I would try reflashing again, because maybe the USB drive is just wearing out, and the data might be written if you try it a second time.

Also, the reason windows doesn’t recognize the drives is because the linux partitions are not compatible with the windows operating system.

thank you for your reply. Diskpart unfortunately thinks “the device is not ready”.
And shows the volume as offline. Disk management instead shows it is online. Neither can access it.
The drive is relatively new and I doubt it is already wearing out.
The two Macs here dont have the USB port anymore (thank you for this worm Apple)

Ok, I see. Can you copy/paste the exact commands you’re entering in with the output as well?

Also, can you tell me the version of etcher you’re using?

Were you able to get this drive recovered by chance, @kungfu ?

sorry for the late reply.
-A friend was able to recover the drive with his Linux. The dd command as described in the link didnt work, but GParted managed it, he said. He actually could access the Linux Parrot partition. Since Parrot created 3 partitions on the drive and I could only format one of them (the last one if that helps) the formatting killed the whole drive I believe. Only then I read up about the
methods describes in the link here or similar methods on other websites. So, I hope with future versions a simple windows format wont made a drive inaccessible anymore.
@zwhitchcox zwhitchcox
-I basically copied all the instructions into the cmd windows but never had luck.
-I used etcher version that is about 2 weeks old.

It broke mine also, if this is a known bug, you have to prevent windows users from flashing using your software…

Microsoft DiskPart version 10.0.22621.1

Copyright (C) Microsoft Corporation.
On computer: WORKSTATION

DISKPART> list disk

  Disk ###  Status         Size     Free     Dyn  Gpt
  --------  -------------  -------  -------  ---  ---
  Disk 0    Online          465 GB  1024 KB        *
  Disk 1    Online          465 GB  1024 KB        *
  Disk 2    Online          931 GB      0 B        *
  Disk 3    Online          465 GB  1024 KB        *
  Disk 4    Online           14 GB    14 GB

DISKPART> select disk 4

Disk 4 is now the selected disk.


DiskPart has encountered an error: Access is denied.
See the System Event Log for more information.

DISKPART> create partition primary

DiskPart succeeded in creating the specified partition.

DISKPART> select partition 1

Partition 1 is now the selected partition.

DISKPART> format quick

DiskPart has encountered an error: The system cannot find the file specified.
See the System Event Log for more information.