Etcher unformats my usb and doesn't seem to flash anything onto the drive.

I’m trying to change my operating system to unbuntu from windows 10 using etcher to flash onto a usb.

I’ve tried 2 brand new usb’s and both seem to be rendered useless now. The exact same thing happened to them both.

I download unbuntu and then download etcher and attempt to flash unbuntu to the drive. Close to or upon finishing flashing, but not finishing validating I get a pop up saying my disk is un formatted but the validating keeps going and then it looks like it’s worked.

I turn off the pc and load it, but nothing changes. I try to click on the drive, but it says I need to format it.

I try to format it but it says it’s write only.

I’ve followed every guide I can see online to remove the write protection but nothing seems to work.

I don’t know why this is happening, but it’s the exact same problem with 2 different usb drives and both now seem to be corrupted.

Can anyone help?

I have the exact same problem!

3 (!) Kingston drives now useless.