Can't do anything with my usb after flash

Hey there,

First of all, i have read some of the others topics similar to mine but didn’t find anything useful.
So i hope someone can help me, to resume the situation i have used balena etcher on my usb drive to flash a linux mint iso and it worked, i have installed my dual boot without any problems but now my usb drive is not partitioned (RAW).

At the end of the creation of my flash usb drive with etcher, it tried to format but it didn’t work due to “write protected” if i remember correctly.

I have tried many solutions before writing this post like run diskpart and the command clean and “create” “partition primary” and got this as results :
“no media in the usb drive and free usable space not found”.
The commande detail disk is also not helping
image

I have also tried testdiskwin and easus which doesn’t recognize/show my usb drive.
Also Active @Killdisk which recognize it but i have no options available to do anything on it

I have tried HP USB Disk Storage Format Tool which tells me there is no media in the specified device.

I have tried to go to properties of the usb drive => Tools => Verify any errors and Windows answered He cannot verify the disk because doesn’t have access to it.

I have all my usb drivers updated and i might have tried some other things but i don’t remember.

If anyone can help me, would be much appreciated

Hi,

Can you please clarify a bit, what do you mean by “installed dual boot but now my usb is not partitioned”? Do you mean you flashed a linux mint iso to a USB stick, used it to install linux on a machine that has windows already to get dual boot? If that’s the case, is the original linux mint usb showing as not partitioned under windows? Are you able to see if you boot into linux?

I encountered a similar problem using balenaEtcher. Like David Copperfield, it made my disks vanish from existence. At least as far as Windows 10 was concerned. I tried using Windows Disk Manager and like you, my operating system wasn’t seeing it (when I say it, I mean 2 USB Flash Drives, and 2 WD 250 Gig HDDs) Can’t say I’m not persistent! Anyway, I downloaded AOMEI Partition Assistant 9.10.0 (free) I was able to see all of my drives and wiped all the partition and reformatted them back to normal. I came to this site to find out why this keeps happening. I must admit, I was successful one time.

Using Etcher V1.7.9 on a windows 10 pc, latest updates & according to Malwarebytes, no security issues.
Trying to use Etcher for a linuxmint file with 16gb usb drive that is new & before doing anything the usb shows as drive F with 16 gb available.
Following the Etcher directions, after finishing the flash process, I have message “flash complete 1 successful target” but also a message that “disk needs to be formatted”
If I try to select the usb now I get a message “disk is write protected” so I can do nothing with it. Can’t view what is on the drive & could not format is even if I wanted to.
If I look at the drive properties, sharing, advanced sharing, the drive appears to be accessible to everyone. (everyone except me ! & I am the administrator)
Tried this 3 x & I now have 3 locked usb drives which I can do nothing with.
I read that others have had similar problems but cannot find anything useful.
I should add that I can use other usb drives in all the normal ways so the issue appears to relate to using Etcher.
Any suggestons would be appreciated
Thanks
Robert

The dual boot is working without any problems actually but the problem is my usb, I can’t do anything with it anymore. Can’t create a partition, format it or anything.

A solution that has worked for me.
Using the last usb stick which I could not access or view on my win 10 pc, I inserted it into the old notebook that I wanted to install Linux Mint on & it installed correctly.
When I then view the usb stick through linux, the files appeared with no write protection.
I then took one of the other, usb sticks that I could not view on the windows pc, I could access that from linux. I formatted from linux & the stick was then useable again back on the windows pc.
So I have a good result & hope that it may assist others.
cheers