Fresh deploy, no audio on two Pi 4's

Hi all, used to use balenaSound until last month when I thought I’d try Volumio.
That didn’t work out great and subscription fees can go away.

The issue is: flashed two Raspberry Pi 4 B’s this evening and deployed successfully.
When I try to play audio via bluetooth or Spotify Connect. The Spotify app says it’s playing, but there’s no audio from either device from the 3.5mm jack.

There’s nothing in the dashboard logs which shows massive errors or any reason why it shouldn’t work.

I’m just a simple guy wanting to have his multiroom audio back :slight_smile:


Hi, can you post the output of pactl list sinks short from the audio container in the balena dashboard?

Looks like there’s a couple of people having this issue at the moment.
I’ve tried re-flashing and new SD cards just to eliminate any other variables.

I am also having the same issue with my Pi4 and my output from “pactl list sinks short” was the same as yours.

1 Like

Any help here please guys?

While I know this is a free product for the most part, it’d be nice to at least have the issue acknowledged?

Just to be sure what is the balenaSound version you are using. Since there was a bug 3 months ago in version 3.8.0 where no audio was being sent.

whichever version is being flashed 14 days ago :slight_smile:


Out of curiosity, do you get sound from any method (for instance audio from 3.5mm headphones but not Bluetooth) or does audio never work from any app or connectivity method?

Audio doesn’t work from any source or any output

@fevington, I wonder if you are hitting this known issue: No sound output with balenaOS 64 bit on Raspberry Pi 3 · Issue #82 · balenalabs/balena-sound · GitHub - have you tried deleting the vc4-kms-v3d overlay from the device configuration and rebooting?

Was this not fixed in later releases?

The issue is still open on Github.

Strange and why would it start effecting me now. I’m using an Pi4 that’s had BSound before with no issues.

I’ll try and see what happens again.

Do let us know if deleting the overlay works for you.


This github comment explains why the issue appeared: Update default DT overlay for Pi 3 64-bit · Issue #1245 · balena-os/balena-supervisor · GitHub
The workaround should resolve the problem (in dashboard go to Device Configuration, find Define DT overlays and remove the value), we will still work to address the root cause, however.