Blank screen after fresh Windows 10 installation of balenaEtcher 1.5.71

Running both as administrator, and otherwise.

CTRL + SHIFT + I says “DevTools was disconnected from the page”.

Hello, could you try opening the devtools then reloading by pressing ctrl + R ? That should show the content of the previous logs too. If not, try enabling logs persistence in the console settings and reload after that.
If this works we should be able to see the error that happens before the DevTools disconnect.

Thank you. Yes, I will just give it a go now.

Download the React DevTools for a better development experience: https://fb.me/react-devtools
You might need to use a local HTTP server (instead of file://): https://fb.me/react-devtools-faq
C:\Users\Graham\AppD…js\dist\raven.js:58 _____ _ _
| | | | |
| |
| |
_| | ___ _ __
| __|| _/ | ’ \ / _ \ '|

| || || (| | | | / |
_
/ ____|| ||___||

Interested in joining the Etcher team?
Drop us a line at join+etcher@balena.io

Version = 1.5.71, Type = nsis
C:\Users\Graham\AppD…js\dist\raven.js:58 Mon Jan 20 2020 18:05:03 GMT+0000 (Greenwich Mean Time) Application start ({“packageType”:“nsis”,“version”:“1.5.71”,“applicationSessionUuid”:“e7fc70d7-c3b9-45fd-a2f2-72d5bb460594”,“sample”:0.1})

Thank you. It seems this could a problem with graphics driver, we had other users report the issue as well on older versions with different electron version as well. Could you try the suggestion recommended in this github comment https://github.com/balena-io/etcher/issues/2866#issuecomment-568914630 and let us know if that works for you?

For some reason, “Run in 640 x 480 screen resolution” is greyed out, so I can’t test it, I’m afraid. I’ve tried Windows 8 compatibility mode, which doesn’t work.

Hi Graham

Do you have a GPU on the machine that you are running this on? Windows applications have the option to select graphics processor

Something like - https://imgur.com/a/1W8qqHC

I do have a graphics card with a GPU on it, but I don’t get the option to select it when I right-click on the balenaEtcher executable. The graphics card is certainly not anything particularly fancy. It’s a GeForce GTX 680, with NVIDIA display driver.

Hi Graham,

A long shot, but could you try changing the compatibility mode to an earlier windows version? E.g. Win7, Win Vista.

No joy, I’m afraid.

I’m now trying to get some kind of insight by fiddling around inside the debugger.

Graham

Hello Graham,

One other possible cause we have seen reported in the past is actually virus scanners believing that the application is malicious. If you take a look here you will see similar reports: https://github.com/balena-io/etcher/issues/2659

Thus, is it possible to disable any Anti-virus or other security software you have running, in order to test?

Thanks,
David

Same problem here on Window 7 Home and Etcher version 1.5.80. Avast Antivirus disabled, no change.

Hi Graham,
have you ever tried other electron applications? do you know if this is the first electron app that gives you this problem?
if you never tried other electron applications could you please try to download one from here and tell us if it works? https://www.electronjs.org/apps

Meanwhile speaking with the etcher team, they suggest you to try to run any application that uses electron version 7, in order to check if it is a generic problem or if it is specific to Etcher.
Here one of the applications recommended by the etcher team that use Electron7: https://www.electronjs.org/apps/camunda-modeler