BalenaSound on Pi4 - it doesn't show up in the dashboard

I’m a new user. I searched the forum and didn’t find an answer.

I have successfully installed BalenaSound on a Pi Zero W and see it in the dashboard. That’s as far as I got with that so far though.

I’m pretty sure I need a Pi 4 as some sort of master device, right? So in the cloud dashboard I clicked on Add a Device and selected Raspberry Pi 4 and Ethernet. Downloaded the file. Installed in on the SD card with Etcher. The Pi4 is connected to the network via Ethernet and does have Internet access when I have other SD cards used. I Installed the SD card in the Pi 4 and waited. And waited. And waited. It never shows up in the cloud dashboard.
Am I doing something wrong? Am I not correctly understanding how this is supposed to work?


After a little more research, I see the green light on the Pi 4 flashing 4x. This appears to be trouble with bootup. I re-installed the image (balena-cloud-balena-sound-raspberrypi4-64-2.82.10+rev1-v12.9.3) using Etcher again and still get the same flashing sequence on the Pi4.

I again reflashed the image - still nothing in the dashboard and still get the flashing 4x green LED.

When I flashed to SD, etcher verified and gave the OK. No errors.

Not sure what to do.

Hi @bmwfan,

First thing to mention is that the Pi Zero can run balenaSound without a master device, it will just run in “standalone” mode which means it’s isolated from any other devices you might have (see Usage - Home).

Regarding your Pi 4, from what you are saying the Pi4 is not being able to boot. Reasons for that will vary greatly, but this section on our documentation is a good troubleshooting start, specially the LED error notifications: Troubleshooting - Balena Documentation.

From experience, the most common error is flashing a Pi Zero image on a Pi 4, that will manifest as 7 quick flashes of the LED followed by a pause.

Ah sorry I just saw your latest message. 4 LED flashes means the device can not connect to the internet, can you verify the ethernet connection?

Thanks for the reply tmigone. And you are 100% accurate.
The ethernet cable was bad. Replaced that and I can see the Pi 4 in the dashboard.
The searches I found at the Raspberry Pi website indicated that 4 flashes of the green LED was a boot problem, not Internet problem. Thanks for that info.

Now, the real fun begins - learning how to get whole-house synced music.

Glad to hear you are up and running, enjoy!