Etcher no longer working in Debian Bullseye, missing libappindicator1

I tried to install BalenaEtcher from the .deb on Debian Bullseye and get the following error message: “The following packages have unmet dependencies:
balena-etcher-electron : Depends: libappindicator1 but it is not installable”.

“libappindicator1” is no longer available in the Debian Bullseye repositories.

Thanks for your help!

Sam

Hello Sam,
I can’t locate the libappindicator1 in Debian bullseye repositories. Still curious if sudo apt-get install -f was able to fetch and install the missing dependencies. Let us know if that works out for you. If not, please do open an issue on Etcher regarding the same - https://github.com/balena-io/etcher/issues We can follow it up there. Thanks.

I opened a ticket on Github. The command “sudo apt -f install” didn’t fix it.

It looks like it is no longer needed since electron 8: https://github.com/electron/electron/issues/10427#issuecomment-567431294 .
Etcher uses electron 9, I’ll remove the dependency in the next release.

Hey @sammycda just wanted to let you know that the issue has been closed.

Hey Matt,

I just tried to install it this morning and still getting the same error message.

Hi @sammycda

Thanks for letting us know, we’ll follow up.

Just to confirm: you were testing Etcher version 1.5.114 this morning?

Kind regards
Alida