balenaEtcher not working when trying to write a drive

I selected the drive and the image I wanted it to write but the Flash button won’t light up and the screen just stays the same. Does anyone know why?

Hey @half-ghoul, first of all welcome to the balena forum : )

Could you please provide more info about your machine and the drive you use? What’s the Etcher version? How about the operating system and its version? What is the image you are trying to flash? Do you see any meaningful error message in the DevTools?

(You can open DevTools by pressing Ctrl+Shift+I or Cmd+Alt+I if you’re on Mac OS)

Um, I’m not sure what version of Etcher I’m using but the setup says 1.5.71.

I’m using Windows 10 Enterprise. The model of my computer is an HP x360 laptop. I am trying to flash a Kali Linux disk image to a flash drive. Not sure the brand of the flash drive since the drive’s title is “USB 2.0” but it has 8.1GB of storage on it.

Can you also paste here the logs output from the console after selecting the drive? You can open it with ctrl + shift + i on Windows. Sounds strange that this happens without any visible warning/error on the UI

How do you get the log output? I’m not very experienced with this software. But yeah, no visible warning/error on the balenaEtcher UI.

You have to focus the application and then press ctrl + shift + i, then click on the Console tab. There’s the logs we’re searching for

Huh. Nothing new appears in the console after selecting the image or drive.

Hi, could you send the full contents of the console output as there may be a clue there, even if nothing new is added. Is this a new SD card or was there something on it before?

There used to be items on the drive, but I deleted them. I’ve had the drive for a couple years.

The full contents of the console:

Thu Jan 23 2020 13:45:07 GMT-0600 (Central Standard Time) Application start ({"packageType":"nsis","version":"1.5.71","applicationSessionUuid":"98b5fe7c-d6d4-4922-83c0-e5545f0700ab","sample":0.1})

Thu Jan 23 2020 13:45:11 GMT-0600 (Central Standard Time) SafeWebview loaded ({"event":{"fromCache":false,"headers":{"Accept":"text/html,application/xhtml+xml,application/xml;q=0.9,image/webp,image/apng,*/*;q=0.8,application/signed-exchange;v=b3","Sec-Fetch-Mode":"navigate","Sec-Fetch-Site":"none","Sec-Fetch-User":"?1","Upgrade-Insecure-Requests":"1","User-Agent":"Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) balena-etcher/1.5.71 Chrome/76.0.3809.146 Electron/6.1.4 Safari/537.36"},"id":13,"method":"GET","referrer":"","resourceType":"mainFrame","responseHeaders":{"Accept-Ranges":["bytes"],"Cache-Control":["public, max-age=0"],"Connection":["keep-alive"],"Content-Encoding":["gzip"],"Content-Type":["text/html; charset=UTF-8"],"Date":["Thu, 23 Jan 2020 19:45:11 GMT"],"Etag":["W/\"3c832-16fd250bc00\""],"Last-Modified":["Thu, 23 Jan 2020 12:11:44 GMT"],"Server":["Cowboy"],"Transfer-Encoding":["chunked"],"Vary":["Accept-Encoding"],"Via":["1.1 vegur, 1.1 vegur"]},"statusCode":200,"statusLine":"HTTP/1.1 200 OK","timestamp":1579808711026.713,"url":""},"applicationSessionUuid":"98b5fe7c-d6d4-4922-83c0-e5545f0700ab","flashingWorkflowUuid":"d4f7f772-b0d3-4dfe-bfc4-7ab226a43246","sample":0.1})

Thanks for the additional info. I found something similar here where they resolved the issue by reformatting the card before flashing with Etcher. Could you give that a try?

Yep! Thank you!

Formatting the drive did not do anything. The problem remains.

Thanks. I’m running out of suggestions here but have you tried running Etcher as an administrator? Also, if you have another SD card to test to rule out any issues with the current one. Also, is this the same problem flashing any image?

Yes, I have tried alternatives. I have had the same issue with all of them.

Meaning I have tried other images. I haven’t tried other drives.

So I looked through some of those replies on GitHub. It said enabling unsafe mode could help with it, but is that really a good idea?

From my understanding that shouldn’t be necessary. You can try, but that setting is there for your safety so please ensure if you use this that you correctly select your SD card (and not an internal drive)

Yes. I will make sure. I don’t think I have any other option.

Please let us know the results of your test with unsafe mode!

Before I try this, what exactly is Unsafe mode for?

Unsafe mode disables the checks that Etcher has, which only allow you to select removable driver or SD cards, essentially preventing you from selecting hard drives, in order to prevent accidental data loss.
Can you also confirm whether this is still an issue while using a different flash drive or an older version of Etcher?

Kind regards,