BalenaEtcher installation hangs on Windows 10

After updating from Window7 to Windows10 the BalenaEtcher 1.5.45 shortcut was gone , the uninstaller was missing but the program shows up under Apps & Features. Because the uninstaller is missing I can’t uninstall it and trying to reinstall it just causes the process to hang about 1/3 of the way through.

BalenaEtcher 1.5.45, 1.5.109 both hang on install.
BalenaEtcher 1.5.70 will install but Windows10 then thinks there are two installations of BalenaEtcher, 1.5.70 and 1.5.45. If I uninstall 1.5.70 it is removed but 1.5.45 still remains.

I’ve seen a couple posts on here that fix this issue byt extracting the uninstall.exe from a zip file. I can’t find any .zip file that relates to a Windows installation.

How would I get a 1.5.45 uninstall.exe ?


“Windows cannot find ‘C:\Users\UserX\AppData\Local\Programs\balena-etcher\Uninstall balenaEtcher.exe’”

Hi John,

Have you tried uninstalling by using Windows 10’s “Add/remove programs”? Sometimes Windows can get stuck with multiple versions and might require a reboot between uninstalls done that way.

Hope this helps. Let us know how you make out.


Hi John,

In Windows 10 when you wish to remove a program you go to the “Settings–>Apps & Features” and then try “Uninstall”. This is where it can’t find the uninstall file executable and I did reboot but it is still showing as installed.

Is there a way to get a uninstall.exe as I can not find it in any of the Windows downloadable files.


Hi John,

I just downloaded the latest installer and found that it placed the Uninstall balenaEtcher.exe file in C:\Users\UserX\AppData\Local\Programs\balena-etcher. In other words, the uninstaller should be added to the Programs directory when you do the initial .exe installation.

As an aside, do you happen to have Chrome Remote Desktop installed on your Windows machine? That’s been known to cause some issues with balenaEtcher. If so, try uninstalling CRD and re-installing balenaEtcher.


Hi John,

I can install and uninstall 1.5.70 without issue. I’ve tried the following without luck:

  1. Install 1.5.70
  2. Copy the C:\Users\UserX\AppData\Local\Programs\balena-etcher directory to a different location.
  3. Uninstall 1.5.70.
  4. Copy the C:\Users\UserX\AppData\Local\Programs\balena-etcher back to this location.
  5. Uninstall 1.5.45.

When I ran the uninstall of 1.5.45 using the 1.5.70 uninstall.exe, it did run but did not remove the 1.5.45 from the Windows Apps. Seems the uninstall must have some knowledge of it’s version?

I do not have a chrome desktop remote(I only run Firefox) so I’m out of luck on that.


Hi John,

Looks like Windows really likes 1.5.45! One thing you might try is booting into Safe Mode and try uninstalling from that environment. I’ve seen cases where many, many versions of apps are “stuck” and can be removed from there. If all else fails, there are some RegEdit tools that can get rid of unwanted apps, but they’re admittedly not for the feint of heart!


Hi, have you tried downloading the Setup v1.5.45 package, extracting it or opening it with 7zip for example, and running the uninstaller that comes with it? That should clear all the installation files for v1.5.45

When you say “package”, what are you referring to? Do you mean the “balenaEtcher-Setup-1.5.45.exe”? Looking in the 1.5.45 downloads there is no reference to a package.

John C.

Hello, yes, the “balenaEtcher-Setup-1.5.45.exe” file. You can open it with 7zip, and extract the Uninstall balenaEtcher.exe file.

I have never extracted stuff from an exe but it worked like magic. Took the balenaEtcher-Setup-1.5.45.exe and extracted it to a temporary directory and then executed the Uninstall balenaEtcher.exe.
This removed the 1.5.45 from Windows 10 “Apps and features” and I was then able to install BalenaEtcher 1.5.109.

Thank you for all the help. Now I have to fix my Virtual Machines which also got hit on the Windows 10 upgrade.

Thanks again,
John C.