Windows10 balenaEtcher 1.5.59 uninstall fails

I get an error that pops up:
Windows cannot find ‘C:\Users\username\AppData\Local\Programs\balena-etcher\UninstallbalenaEtcher.exe’

I had 2 versions installed and tried to clean things up so I only have 1. I can install 1.5.64 and it seems just fine. I tried to install 1.5.59 again and it gets about a third of the way and it just stops and doesn’t appear to use any cpu or make any progress.

If I have both 1.5.64 and 1.5.59 installed and I click on uninstall on the 1.5.59 one it uninstalls the 1.5.64 version.

I decided to try some things. I installed 1.5.64 and then I installed 1.5.59 and it worked and when I did that it removed the 1.5.64 version and then I was able to uninstall the 1.5.59 version. So then I was left with all versions removed. I then was able to install 1.5.64 again and I am good.

I am going to leave this, maybe it will help someone else.

Hey @jwilliam welcome to the forums and thanks for sharing your solution. It’s very appreciated and will likely help others! In the mean time we’ll look into a solution for this.

You can go to this link to download the previous version:
Then you can uninstall the program once you have installed the same version.