Balena Cloud release stuck on "Factory Default"

Im testing Balena Cloud and I found it so handy for my project.

I am trying to deploy this repo balenalabs-incubator/balena-wpe: Fullscreen WebKit browser with hardware accelerated CSS, WebGL, and HTML5 video for the RaspberryPi 3. (

I push it correctly by balena push <my-user>/<my-fleet> --source path/to/local-repo

It builds right and it pushes so now the fleet target is the new build.

The issue is It never runs.
The release shows 0 devices
The devices current release is stuck on Factory Default
The devices target release is right pointing to the new release.

Is there something I am missing?

Thanks you!


For some reason, this isn’t happening anymore. Current Release now comes in “updating” state, images are now downloading and deploying flawlessly with no issues.
I didn’t make any changes just the same tries. So I think there was some trouble with Balena Registry or something like that.
I mark this as solved now.

Thanks for your support

1 Like

Hello @mrcbns welcome to the balena forums!

This is really odd, as I don’t see any outage on the builders or API on the 8th October here.

Glad that everything get solved :slight_smile: