balenaOS is not pulling latest release

I have pushed multiple config changes since 8c28100, but the device (raspberry pi 3b+) wont pull the latest release. I have let it sit for a good thirty minutes thinking it might not have been contacting the balena servers for it, but it just isnt working at all

Hello @merith.tk over the last hours we have experienced an elevated level of API errors. The issue has been identified and a fix is being implemented.

Could you please try again and check if it’s working? Thanks

I’m finding the same thing, released don’t seem to consistantly be pushed to the remote devices, I’ve been waiting over an hour this morning for a build to be pushed to my device.

Hello @rbezemer welcome to the balena community!

Could you please confirm that you can deploy new releases now?

well I was able to push them this morning, but for the last week the devices don’t seem to be downloading the target release:
image
this has been in this state since I pushed a release 2 hours ago, and previous to that I had a release that was pushed almost 2 weeks ago that still hadn’t downloaded onto multiple devices.

I’ve also tried updating the BalenaOS and supervisor this morning and haven’t noticed any difference.

well my containers are now updating, but the device still says its release is not the latest

Any update on this issue, not being able to update containers is a massive issue, I’ve been trying to deploy an update to our devices off and on for almost 2 weeks now and almost constant api issues have been preventing us from deploying anything it seems.

this issue doesn’t seem to be resolved yet, as I have multiple devices that are still not pulling updates.