Infinite Building/Updating RPi3


Sorry if this is the wrong place, but I am just getting started with Docker/Balena and I’m looking to potentially use BalenaCloud for scaling deployment in the future.

I am struggling to see why my Release gets to a percentage and then fails and resets to 0% again. I cannot see any error logging in the consoles etc.

Any help would be appreciated. Thanks in advance.


Sorry to hear you are havaing issues. Where are you seeing this failure, in the command line/CLI? If so, is it reporting any error?

Thank you


I was seeing this issue in the balenaCloud web portal/GUI.
I have since “resolved” this issue by using the 64 Bit Beta version of the image on my Raspberry Pi3. The original image without the (BETA) tag just loops forever updating in the web portal.


Hey there,

Nice to hear you fixed it. Let me double check with the balenaOS team that this is a known bug fixed in the later versions, just to make sure we understood what caused it, and whether we thought about back porting the fix as well.

1 Like

Ok, so I have been building and developing on my Pi3 with the BETA Host OS Version and this has been working fine.

But I have now just tried to run the same code and application on my Pi4 and I am having the same issue as I originally did.

The 3 services keep trying to download and get to varying percentages before all resetting back to 0% and starting again.

The only information in the logs is as below:

30.01.20 12:19:19 (+0000) Supervisor starting
30.01.20 12:19:23 (+0000) Downloading image ''
30.01.20 12:19:23 (+0000) Downloading image ''
30.01.20 12:19:23 (+0000) Downloading image ''
30.01.20 12:26:24 (+0000) Supervisor starting
30.01.20 12:26:26 (+0000) Downloading image ''
30.01.20 12:26:26 (+0000) Downloading image ''
30.01.20 12:26:26 (+0000) Downloading image ''
30.01.20 12:33:32 (+0000) Supervisor starting
30.01.20 12:33:33 (+0000) Downloading image ''
30.01.20 12:33:33 (+0000) Downloading image ''
30.01.20 12:33:33 (+0000) Downloading image ''`

The above just keeps repeating over and over, every 5-10 minutes or so. My other device (Pi3) is stable on the same Application and updates and gets information just fine.

Are you using the same beta release of balenaOS on the Raspberry Pi 4?

Thanks for the quick replies :slight_smile:

I am using the 3rd option below for my Pi3 and the 4th option below for my Pi4


hey @kildcael,
thanks for getting back. Can you confirm that you have enough space on your sd card for the Pi4?
You can check this from your device dashboard page and going to the Diagnostics tab and running Device Health Checks. The check_diskspace row should give you the status.


I will check this shortly, but at the moment I believe this is unlikely as it is the same SD card (model and size) as my Pi3 is running. (32GB)
edit: see image

Also here is my dump from my Device Diagnostics:

hey @kildcael,

there is something going on with the device supervisor. Also, there is only 11% free disk space.

can you please grant support access to the device and share the device url in a private 1-to-1 message with me please? I can then look into it.


Support Granted, will PM now.

Also, I don’t think there is any way that my Application can be using around 28GB of the free space, even with the BalenaOS overheads.
I’d be surprised if it was anything over 3GB.

Hi, it looks like storage is corrupted. Can you reboot a device? balenaos might be able to fix the corruption.

Rebooting now

SD card is corrupted most likely. Can you try flashing another card?

Yes, will do.

Should I use the recommended build below?


Yes please.

…this seems to now be working fine on a new SD card.

The failed SD card was brand new too. Kingston Class 10 32GB. Must have been DoA.

Thanks for the great support.

Good to hear that it works fine now.