3 USB drives not usable anymore


i have been a user of the etcher.io flashing tool for quite a while now for it’s simplicity. It never caused me any problems. The last time i used it however it caused me quite a lot of trouble. Without me realizing it rendered 3 USB Sticks completely unusable for everything but the image that i flashed onto it with etcher.

All of my drives behave the same after having ether flash (different) images onto it so that’s why i think etcher caused the problem.

I am currently only in possession of windows machines so I need a way to repair it in windows. (I am trying to flash a linux install image onto it - however no flashing tool recognizes the drive)
After trying to format the stick with the windows partition manager it basically gives me an error telling me to try again. Obviously i tried that - sad to say it didn’t work.

I am a CS student and actually quite experienced with computers in general so I tried DISKPART and some 3rd party tools. I was to this day not able to restore my drives.

Diskpart tells me ‘permission denied’ when I try to ‘clean’ (i did run in admin mode of course)
Windows itself does recognize the device but doesn’t mount the device so I cannot use it.

One tool i used made the drive be recognized by windows but it only worked until i removed it from the slot and inserted it back into it.

I am really helpless since the stick was quite expensive (USB 3 and type c as well as type a)
I do not blame your Company or expect some kind of payment,

I would really appreciate some help in fixing my drives though since I don’t seem to be able to do it on my own.

Thank you very much in advance and have a great day, Jo Bettaque

1 Like

Hey there!

I had the same problem today ( I suspect), and in my case, the drives were left with unrecognizable, unallocated space.

I managed to create a new partition in that space using Diskpart, as well as AOMEI Partition Assistant, which is a GUI program ( Freeware ).
In AOMEI PA, which is basically a Frontend for Diskpart, the unallocated space was recognized ( as in Diskpart itself ), as opposed to the Windows Partition Manager, which wouldn’t show the drives.