2 USB Drives now unrecognizable and not bootable after flashing

I used a PNY 16 gb usb drive and a 64 gb datastick pro by ecenton and flashed a linux iso onto each awhile ago. One was CentOS 7 and the other was either Ubuntu 19.04 or Fedora 30 workstation I don’t remember which. I just now looked on the balena forums and found several post about bootable usb’s being killed/unreadable/unrecognizable and tried the balena team’s usb recovery method on gitub but received an error in the process. the error happened after I selected the usb drive (I tried on both and received the same error on both) and performed the “clean” command. Error says “DiskPart has encountered an error: access is denied. See the SystemEvent Log for more information.” Another error pops up in another window telling me “the directory name is invalid.” I tried this on my account on the computer and the administrator’s account on the computer and received the same errors. Any thoughts on how to recover these drives? The old computer that I am trying to install these OSes on only can boot from a usb drive or the HDD.

I’ll be happy to recommend a course of action, but I should mention first that this is where we support balena OS, balena devices, etc. and it seems your issue is with the windows command DiskPart and permissions / the expected contents of the disk, something we don’t support here. That said, my advice is to google those error messages and see if there are forums where people are discussing this more general DiskPart issue. Feel free to reply if I’ve misunderstood and this issue touches balena services or technologies in some way. We’ll be glad to assist.


Mini Partition tool, is the best free tool I have encountered.

Many things can go wrong when flashing USB drives, but it is possible that the tool above might at least give better error messages. I have no further help to offer.


Issue resolved. I created the live usb’s on gnu/Linux with balenaEtcher. That must’ve somehow made them incompatible with Windows so when I plugged them into a gnu/Linux computer they worked fine and I could wipe and reformat them. Thanks for your time dt-rush and tacLog.

1 Like