Strange behaviour - breaking USB drives

Hi there,

I have used Balena Etcher hundreds of times all worked fine.

Today I tried to flash an ISO with crucial firmware update tool to an usb stick. First it worked, tried to boot, didnt work. Okay wanted to reflash. Didnt work to flash. Sure use diskpart and clean (W10), what? clean not working, access denied. Checking the event log "sectors cannot be put to null. 5@010100F - strange. Downlaoded AOMEI partition tool. It said it did everythign fine, but windows wont recognize the drive. I then tried to change the registry Error - "storagedevicepolicies" is missing | Media is write protected

Didnt help either. Okay USB drive (Lexar) might be broken. Try another one. Same thing. So basically two bricked, USB drives - anyone any idea?

Apparently it has to do with MBR record created. I changed it back to GPT - with paragon, then it worked. Sorry - please delete, if you think it is not suitable here

Interesting catch though, switching MBR will definitely cause issues. I will leave the post here though, in case anyone else runs into something similar. It’s a good reminder that many times drives don’t really die, they just have to be restored back to a working condition. On the other hand, sometimes, they do certainly fail. :slight_smile:

1 Like