I used balenaetcher.io desktop program to flash my usb and it destroyed my usb

I used etcher to flash a linux iso file, neither did it work but it made my usb unrecognizable to my pc, I thought it happened because it was an old usb so later I bought another usb for 20 dollars and it did the exact same thing all over again. Now I have 2 worthless Usbs which cannot be detected from any device and I cant either find them on diskpart.exe. Please somebody help me this is getting really irritating

Hi @ersjan,

Can you tell us what platform you’re on and the version of balenaEtcher you’re using?

Thanks,
John

Hi John, I am on Windows 10 and I was using the latest version of Etcher for Windows x64 (Installer). Do you need any additional information?

Hi,

When you say the USB isn’t recognized by your PC, do you mean while running Windows or when attempting to boot off the newly written USB? If you’re still under Windows, there’s a good chance it doesn’t recognize (and doesn’t see or mount) any Linux partitions. Sounds like you already tried steps outlined in this blog post.

John

No it isn’t recognised while running windows, when I attach the usb stick it doesn’t show up. It failed the flashing process because it required a formatting but meanwhile it got reduced in some way into a 2 gb usb (it a 64gb stick) and an additional icon in red with 4 kb storage… The point is that I cant even format it right now as of I doesn’t show up when connected to the usb port (it also doesn’t show on diskpart.exe I already tried it)

I believe it isn’t recognized by Windows because it’s now formatted with Linux partitions. I also assume the .iso file you wrote to the USB created its own 2GB partition for its files – or started to. Have you tried booting a device from either flashed USB?

Something else you might try is running Windows Subsystem for Linux on Windows 10. That’s essentially a Linux VM and should allow you to mount the USB and otherwise interact with it using Linux fdisk and the like.

John

1 Like

hi John,
I would gladly appreciate a more thorough guide if you could, I have an ubuntu 20.4 lts installed into my os installed from microsoft store but I don’t know whether it would work so can you help me please ?

Hi,

This is a good guide to running Ubuntu on Windows 10. I’ve found it to work well, though initial setting requires a reboot and some niggling with Windows settings. There are a couple steps, the first of which is enabling the Linux feature and then using the Microsoft Store. Depending on the horsepower of your PC, the initial launch of Ubuntu (or other Linux OS you choose) and take a bit of time to download and launch.

Hope this helps!

John

Just asking, is there any other way to make my usb stick recognizable? I mean does it not show up on windows only or any particular os ?

Sir, I have already installed a linux subsystem on my machine, as I told you it was ubuntu 20.4 lts it seems it the exact same one as the guide you sent me. I tried fdisk command and then fdisk -l which was supposed to list the partitions but there are none, what should I do ?

Hi,

When you insert a Linux-formatted USB into Windows, it generally will not show up. It’s a Windows thing.

In the Ubuntu environment you installed, try running the lsblk(after you’ve inserted the USB stick into your PC). If you still can’t see your USB, then WSL won’t work. You still have some other options, though, as described in this post.

You can also try booting your PC from the USB. If it was written properly, you should get an interactive screen on how to proceed (boot from USB, install to disk, etc.). This largely depends on the Linux OS you flashed. If it’s a “Live” image, you can run your system off it.

John

Hi,
the command lsblk gave me this error: lsblk: failed to access sysfs directory: /sys/dev/block: No such file or directory
I don’t believe the booting was succesful on my usb by I wouldn’t be able to know either way because the usb isnt recognised even in the bios, it doesnt show so I am pretty much out of options.
Do you have any other option ?

Can I access this usb then from a linux machine?

Hi,

It’s likely you can access the USB on a Linux machine. Follow the same procedure: insert the USB and run lsblk from the Linux terminal. If it comes up with something like /dev/sda3 with a mount point, you can then interact with it using fdisk there – even if it doesn’t auto-mount.

John

with what command line can I format my usb to its fabric state then ?

Hi,

From the Linux terminal, run the following (replacing your device for the sda3 in my sample):

sudo fdisk /dev/sda3

You’ll get the interactive fdisk menu and can type m to get the menu

John

Hello sir, i tried everything that you told me, but even in linux the usb is still unrecognizable, it doesnt appear on sudo fdisk -l and right now I dont know what to do

I cant even get the name of the usb from fdisk -l as, it is completely bricked i thought that sticking it on a linux would work

Hi

Can you try gparted? Its a GUI application that will show all the disks that are available to your system. If possible share a screenshot of what you see in gparted in the drop down in the top right corner. For example, on my Linux machine I see the following -

Hi sir,

The dropdown consists of only the machine’s hard disk no clue of the usb