Writes Fail On WIn 10

I’m trying to write an img file to an sd card, but it fails every time. I’m using win 10 and Etcher 1.5.78.

Here’s the log info:
Thu Feb 20 2020 13:25:21 GMT+0100 (Central European Standard Time) Input/output error ({“image”:“C:\Users\phill\Downloads\2020-02-13-raspbian-buster-full.img”,“drives”:[{“size”:31312576512,“isVirtual”:false,“enumerator”:“USBSTOR”,“logicalBlockSize”:512,“raw”:"\\.\PhysicalDrive3",“error”:null,“isReadOnly”:false,“displayName”:“F:\”,“blockSize”:512,“isSCSI”:false,“isRemovable”:true,“device”:"\\.\PhysicalDrive3",“busVersion”:“2.0”,“isSystem”:false,“busType”:“USB”,“isCard”:false,“isUSB”:true,“devicePath”:null,“mountpoints”:[{“path”:“F:\”}],“description”:“Generic MassStorageClass USB Device”,“isUAS”:false}],“driveCount”:1,“uuid”:“a14a238d-9dd0-47fa-93e3-71d0c1ffaa4f”,“flashInstanceUuid”:“a14a238d-9dd0-47fa-93e3-71d0c1ffaa4f”,“unmountOnSuccess”:true,“validateWriteOnSuccess”:true,“trim”:false,“applicationSessionUuid”:“dcaadcc3-4a7e-47bd-a14b-9eb5fccabb3d”,“flashingWorkflowUuid”:“8c83334a-55f3-43cb-9d55-7ba6c526f278”,“sample”:0.1})
C:\Users\phill\AppData\Local\Programs\balena-etcher\resources\app.asar\node_modules\raven-js\dist\raven.js:58 Thu Feb 20 2020 13:25:21 GMT+0100 (Central European Standard Time) Flashing 0 devices, 34% at 0 MB/s (total 0 MB/s) eta in undefineds with 1 failed devices
C:\Users\phill\AppData\Local\Programs\balena-etcher\resources\app.asar\node_modules\raven-js\dist\raven.js:58 Finish: 2512388096

hey @Phill,
Welcome to the forums. Can you please provide some additional information regarding your workflow and setup, please?

  1. what type of installation are you using - installer or standalone?
  2. when does this happen, while writing or validating the disk?
  3. Does a message pop up at any point during the process saying
Looks like Etcher is not able to write to this location of the drive.
This error is usually caused by a faulty drive, reader, or port.
Please try again with another drive, reader, or port.


I’ve used both the installer and standalone. The error was previously occurring during validation however it has recently started failing during writing and it seems to be at approximately the 34% stage (this is where the provided logs are from).

On occasion it appears that Windows 10 is issuing a pop-up window that states the device needs formatting. My suspicion is that this is what’s causing the issue, but I can’t figure out how to stop it.

I’ve tried writing with both the built in sd slot and an external card reader, without any success.

Can you try with another card or usb device?

Also, the pop-up indicating to format partitions is expected since windows cannot mount the linux based filesystems the partitons use. if the flash was successful you can try the image.

I’ve tried this with several different cards on 2 different readers using several different images. It’s been going on for some weeks.

seeing as this can also be related to the port, can you try on a different one?

Also, at any point do you see the following message

Looks like Etcher is not able to write to this location of the drive.
This error is usually caused by a faulty drive, reader, or port.
Please try again with another drive, reader, or port.

in a dialog?

No, nothing like that ever comes up. What do you mean about a different port?

try to plug the card reader in a different usb port on your computer

Ah, yes, I’ve done that too.

Hello !

it has recently started failing during writing

Do you know what might have changed ?
Newer etcher version ? Windows update ? Flashing a different image ?
Are you using the zip file or have you extracted the image first ?

I’ve just flashed the same image using etcher 1.5.79 from the zipfile with no errors.
I don’t think the windows format dialog prevents the flashing (I get it too).
If the flashing always fails around 34%, could you try flashing a smaller image.
Raspbian Buster full is 7.32GB,
7.32 * 34% = 2.48GB
Please try flashing a 2GB image to this SD card.
If it works, I would suspect the SD card having problems around 2.48GB.

Even with other cards of differing sizes and from different manufacturers, I have issues.

There’s not enough information for me to help you here.
Have you tried flashing raspbian buster lite to the same sd card that was failing at 34% for the full raspbian (It’s less than 2GB) ?
If yes where did it failed ? Did you get any error message ?

Yes. I’ve literally been unable to write anything to any card on any device attached to my laptop. I’ve even tried Win32DiskImager without success.

Some users have had issues with Windows defender real-time protection (strangely I don’t have any).
Is it enabled on your computer ? Does disabling it help ?
What was the error on Win32DiskImager ?

I figure it’s got to be something system-wide that is grabbing control of the sdcard preventing it from being written to. I’ll check the Win Defender and let you know.

I’ve actually checked the SDcard on another Win10 system and they wrote the image without issues.

Yes, so it sounds like something locally on that particular machine is preventing writing to SD Card. The best way to troubleshoot it is to start disabling any anti-virus, anti-malware, or enterprise software that might be interfering. If this is a work device, sometimes specific profile and permissions are controlled at the User Account level, that can also have an impact. Good luck with narrowing it down!

I made this account just to comment.
In Win10 there is a option for “real-time protection”
IF you have this enabled ANY etcher will fail to start and will NOT complete.
I have tried to add an “exception” for the flash drive in question but for some reason the exception will not take. You will have to FULLY disable the protection to get this to work!

Hope that helps all who stumble across this thread!