BalenaEtcher not flashing to External SSD on Win 10 64-bit

I downloaded and installed the latest version of BalenaEtcher a few days ago to flash my brand new Samsung T7 SSD.

The SSD is formatted after watching this video. I lauched Balena and started flash. After about 10 minutes, it stops at 44% and returns the following message:


Looks like Etcher is not able to write to this location of the drive.
This error is usually caused by a faulty drive, reader, or port.
Please try again with another drive, reader, or port.


This error occurs every time it reaches 44% flashing. I tried troubleshooting this problem and reading posts and yt videos to solve the problem with no luck. For example, re-partitioning the drive, disabling Windows Defender and real time protection after reading this post, and cleaning the drive after reading this post. I will say that I read on another site that you want to be careful cleaning/erasing the drive too many times because it could damage it permanently.

Could someone please help me fix this problem? I have no idea why it keeps freezing at 44% mark during flashing.

Hi Ron,

What are you trying to write to your SSD? Are you trying to clone another disk or flashing an image (the process is not exactly the same).

If you are trying to clone a disk, I would suggest to avoid doing so on a currently used disk (e.g. you computer drives), if this is what you are trying to achieve, I would recommend booting your machine from a linux live usb stick and run Etcher from there (that way the disk is free to be read and copied). However, this is not the indented purpose of Etcher, which targets creating boot disks for Linux systems, and copying a Windows system might not work as you expect.
Also: Beware not to erase your main OS disk.

If you are flashing an image, what kind of image is it ? (size, OS)?


Hi Aurélien,

I thank you for responding. I am flashing a Linux-based OS that I will run on Raspberry Pi 4 model B. The size is 14gb.


Thanks for the precision @flashdance.

Is your image compressed (e.g. image extension is .img.xz)? I know we have a work-in-progress to fix the XZ decompression.
At the moment it tends to fill the RAM of your computer for large image (let’s say you have a 14GB .img.xz file, if your computer has too few RAM, it generate the behavior you are describing).

If it is she case, try flashing the decompressed image (unzip the image as .img with a compression software like 7-zip and select the decompressed version.

Let us know if it works.

I did flash the unzipped file because the instructions required the .img files be flashed. I thought the problem was Win 10 so I I tried zipping the extracted torchie OS to .tar (so I can flash the unzipped image files on a Debian usb stick afterwards) but it is stuck at a point less than 50% so I took the following screenshots to show exact image that is causing error message. This tells me that the problem is with the torchie OS so I notified the developers of this distro: " I have spent so much time and energy just trying to flash torchie OS and troubleshooting the problem by posting on Balena Etcher, re-partitioning the drive on Win 10 at least 10 times, attempting to flash the OS from a bootable Debian usb, watching yt videos." The devs will be releasing an updated torchie OS without the database so I’ll flash it when the lastest stable OS is available.

The devs did release an updated torchie OS without the database. Again, I had problems flashing (data error messages with 7zip and read error with Winzip but Winzip allowed me to ignore error and continue) with Win 10 so I unzipped the .7z and copied the .img file to my usb bootable Linux Debian with 32gb storage. The .img file is 14.6gb. The Linux Balena Etcher .img file I downloaded is not executable so I read How to Install Etcher on Linux - GeeksforGeeks and there is an option to “Allow executing file as program” so I can run Etcher but this option is NOT available on my Linux machine. Could someone please help me fix this so I can run Etcher and flash the torchie OS to my Samsung SSD hard drive?

FYI: In addition to Win10 errors, Windows always asks me to “allow this program to make changes” and the program is some type of Windows command program that needs to run in order for Etcher to work and I got the blue screen of death the last 2 times I tried running it. As a result, I only want to use Etcher using Linux to avoid these frustrating problems.

Thanks for a solution. Please help me with the “allow excuting file as program” by sending me a direct link to Etcher with this option or the lastest version with this option included for my Linux Debian.

Hello, just to confirm, you have downloaded the AppImage file for Linux from balenaEtcher - Flash OS images to SD cards & USB drives ? Which Linux distribution are you running on your Linux machine? On Debian-based distributions like Ubuntu, you can right click on the downloaded file, select “properties” and on the “permissions” tab you should see a check box for “allow executing file as program”.

Yes, I downloaded the image file for Linux onto my Linux Debian machine and the option for “allow executing file as program” does NOT exist. The instructions are in the link I shared with you. I can send Windows screenshots but not Linux screenshots. I tried to create Linux screenshot using [PrtSc] + [Alt] but it doesn’t work. Thanks.

Update: I just checked the Linux distro By typing “lsb_release -a”, you can get information about your current Debian version. I actually have Raspbian GNU/Linux 10 (buster) version not Linux Debian which I had paid for on the usb drive.

Question: Is it possible to switch my usb bootable disk from Linux Raspbian to Linux Debian? Will I lose the files on my desktop – it’s ok if they are lost but want to ask. If I can make the switch, what instructions to follow in terminal?