Windows 7 Blue screens after verification step

Three times now , Windows 7 has blue screened , in this strange way (the border color is green??)

Using Etcher Portable. No other problems using ANY other software. The image copies to usb, and verifies 100%, and then without any user interaction , hard crash. Not sure, but it may have been attempting an auto unmount just before the crash (the flash was an image of a Linux build)

And the usb flash works fine when booted.

MULTIPLE_IRP_COMPLETE_REQUESTS seems to be the cause.

This is the first line of the dump as reported by BlueSCreenViewer

062919-9360-01.dmp 6/29/2019 12:37:31 AM MULTIPLE_IRP_COMPLETE_REQUESTS 0x00000044 fffffa800bd57af0 0000000000000ec0 0000000000000000 0000000000000000 CLASSPNP.SYS CLASSPNP.SYS+24d1 x64

The ‘caused by driver’ information seems bogus. I deleted the driver it claimed was the cause the first crash, and it just seems to pick on some random driver to blame. Definitly Etcher causing this .

Hi @gradskool2 , thanks for the report. Does the blue screen also happen if you disable the “auto unmount” feature, you can find it in the settings panel. That will indicate if the unmount code path is causing the crash.

I’ll try disabling that the next time i need to flash a usb drive.

Have you ever seen that color for a blue screen border ?? I haven’t . Did that all three times it crashed

Nope, never seen that kind of bluescreen (although I haven’t used windows in about 10 years). I think some of the etcher engineers should be able to offer more info hopefully.

I have the same issue, same blue screen on completion with Windows 7

balenaEtcher Support needs to look into this. I just had the same thing happen on a Windows 7 x64 system, three times.

“This issue occurs because of a race condition that is caused by a reference counting on lease.”

Unfortunately, this is something that we can’t do anything about as it’s how Windows 7 works, which can cause that issue in some specific configurations as you can see here https://support.microsoft.com/en-us/help/2552033/0x00000044-stop-error-on-a-computer-that-is-running-windows-7-or-windo
The link above also contains a “hotfix” that afaik has been integrated with newer versions of Windows as seen here https://support.microsoft.com/en-us/help/4343220/this-hotfix-is-no-longer-available (found by clicking “Update available” on the first link containing the hotfix)
Generally speaking, a BSOD is hardly Etcher’s fault. We had another report of a user seeing a BSOD here https://github.com/balena-io/etcher/issues/1839#issue-273013190 for example but I admit that situation was different (it happened after flashing with Etcher and connecting the USB), while here it is right during Etcher’s usage, but much like the other one, we can’t do anything about it other than look for the error code (0x00000044) and find anything useful for you (description, explanation, fixes by Windows if there are any, etc)

I hope this clears some doubts!

Thank you for your prompt response.

Please where could I find system requirements for Etcher, in particular supported/recommended operating systems.

Hi @wendiee,

Here is a list of Etcher supported OSs:

This issue apparently goes back to 2011 !!!

You say it’s not Etchers fault, but I would think you would look into exactly what’s causing etcher to invoke this error and work around it.

I run 100’s of programs over the years and its very rare to have one cause a blue screen. I get that you are doing ‘low level’ i/o but still…

You see others here are reporting the same issue, which means that you will have quite a few users having their machines blow up with this error. Since in my case , a blue screen is a once a YEAR thing if that , I find it quite disturbing

Don’t want to sound repetitive here, but I guess I need to: did you read the error description we linked above and try the hotfix that, by the way, was released by Microsoft because it’s a Windows 7 issue?
Yes, it’s a pretty old issue; no, it’s not Etcher: it’s a Windows 7 issue as you can see in the error description and related links.

A) the ancient hotfix is no longer available

B) the file in question Srv2.sys , has already been updated to a much more recent version , assuming that is the only file that was changed.

It is the only one named in the MS KB article.

I get that if you cant replicate the error on your end, fixing it would be near impossible, but I’d guess there is some code that could be tweaked.

@gradskool2 have you tried disabling the “Eject on success” option in the settings? Does it still crash?

Sorry, haven’t needed to use the pgm since, and didnt’ feel like causing a crash as an experiment.

Maybe someone who also has had the problem can try it.