Blue Screen when etching Android Things Raspberry Pi Image

Hey guys,

I have an issue etching a custom image I released through the Android things console. I wanted to get a boot animation for my IoT device, thats why I got a custom build.

I tried multiple builds, multiple PC´s and all have the same issue. It is either right away at the start of the flashing process, half way through or during verification. If it happens during verification the build usually works, but it still feels like I´m giving my laptop cancer. I had like 20 blue screens by now.

The codes I get in the blue screen are either

has anyone an idea what could cause that and what I could do about it?

thanks for your help!

Hi there, what operating system are you running etcher on? thanks

Windows 10, 64bit

Hello Andre,
Can you confirm what version of balenaEtcher are you using and if you tried disabling the “Eject on success” option in the settings? Does Windows still crash after that? Thanks!


I´m using 1.5.102, which I believe is the latest version and I switched Eject on success and validate off to minimize the crashes.
From a bit more testing it seems like an SD card fresh out of the box is working without crash, but I can´t reflash it once it had the Android things image on there. The card appears as 64MB size, balena usually recognizes the 32GB, but even if I do a slow format it still has a high chance of causing a blue screen. Unformatted it almost certainly crashes.


the reason you see 64MB is because that’s the only partition that the OS can read, but of course the device itself still has all the disk space so don’t worry about that.
You could try temporarily disabling DEP on Windows and see if that helps, unfortunately there’s not much we can do about a BSOD besides trying to see what part of the OS caused it. I think you would find more helpful resources looking for those error codes on Windows support.


thanks for the tip, I´ll give it a try.