Windows 10: something went wrong

Windows 10 version 1909, Etcher 1.5.109

I keep getting en error message “something went wrong. if it is a compressed image, please check that the archive is not corrupted”. while writing hassos_rpi4-64-4.13.img

Hi @tyo!
Could you please let us know if you see any meaningful error information in the DevTools?
You can open DevTools by pressing Ctrl+Shift+I.

Thanks,
Georgia

I’ve also found this GH issue on the etcher repo https://github.com/balena-io/etcher/issues/2859. Could you please also try and run etcher as Administrator and let us know if this works for you? Thanks

Thanks Georgia. Running it as administrator seems to make the difference. I am still a bit worried because of the message “Flash Complete! 1 Failed target”.

You should see a more specific message in a tooltip by hovering over the failed targets. It could be a verification error due to Windows writing an SVI folder when we switch from writing to reading data for validation

it is also not working

Use this option to to access give balena to sdcard and reinsert the card problem solved
follow me on- https://www.youtube.com/channel/UC9ufAseSDfIDdbhuQa9TwdA

1 Like

Hey @techboystoys thanks for the suggestion.

@goldegg can you please try that and see if it works?

Thanks

It’s working my friend. I have done with it😊

That’s great to hear, nice one :slight_smile:

Sentence mistake
Use this option to give access balenaetcher to the SD CARD and reinsert the card and flash the os, problem solved

yes now it’s working
thanks everyone for helping so quickly

Dear ones, Even I am looking for a solution to the same problem, I am unable to find these features in Windows 7 ultimate edition, any help on this will help me great deal. Thank you.

@hfnrisheeb I can see you have created a new post about your issue, so we will reply over there Windows 7 : something went wrong. if it is a compressed image, please check that the archive is not corrupted.

As far as I’m aware, Windows 7 doesn’t have a “controlled folder access” like Windows 10, so I think probably your issue is slightly different.

Hello i’m here for the same reason. I’m tryng to install Home assistant for raspberry and after i FLASH show me “Something went wrong …” How can i risolve? Thank you. I tried also on “allow an app through controlled folder access”

What version of Windows are you using Luigi? Looking at this thread, I see some folks had Windows 7, and some were on Windows 10. Out of curiosity, even with the error in Etcher, if you place the SD Card in the Pi and boot it up, does it work?