Something went wrong. If it is a compressed image,

I already searched previous posts for this error but my problem is not resolved

I downloaded tails operating system and it verified as legit via chrome plugin
Then I downloaded etcher from the same site to flash tails on my sandisk USB
as far as I can tell, sandisk is not on the list of problematic flash drives

every time, it gives an error “something went wrong. if it is a compressed image, please check that the archive is not corrupted”

I am on windows 10 64 bit
I have tried running as admin, same result
I have tried control alt i but nothing happens

Hello @nancyba

Welcome to the balena Forums.

We do have users who have successfully managed to flash Tails OS using balenaEtcher as reported here: Etcher successfully flashes a USB with Tails 6.4 img and validates, but doesn't boot

Please could you provide details of the Tails OS file you are using, details of the version of balenaEtcher that you are running and also post the contents of the developer console when the error has occurred? You can get to the console by pressing CTRL+SHIFT+I.

You could also try using the latest version of balenaEtcher which is available to download here: