[wifi-connect launch on boot] Failed to start Advanced IEEE 802.11 AP and IEEE 802.1X/WPA/WPA2/EAP Authenticator.

Hi there! I’m running in a bit of an issue when trying to make wifi-connect run on boot on my RPI-Zero-W setup using Raspios Buster Lite ARV6l.

I followed these instructions from @libbymiller.
Here’s the link to the guide:

When trying to boot my RPI-Zero-W, I don’t see the access point. So I tried plugging in my device on the monitor and checking the logs.

I ran the ff. command:

sudo systemctl status hostapd.service

This returned the ff errors:

Failed to start Advanced IEEE 802.11 AP and IEEE 802.1X/WPA/WPA2/EAP Authenticator.

I tried running wifi-connect manually on the terminal and it worked fine.

Reading through forums I saw that one solution that helped remove this error was changing the hostapd version to an older one using the following commands:

$ sudo su
apt-cache madison hostapd hostapd | 2:2.6-21~bpo9~rpt1 | http://archive.raspberrypi.org/debian stretch/main armhf Packages hostapd | 2:2.4-1+deb9u7 | http://raspbian.raspberrypi.org/raspbian stretch/main armhf Packages apt-get install hostapd=2:2.4-1+deb9u7 -V
exit sudo reboot

After rebooting, the access point appeared but the “Failed to start Advanced IEEE 802.11 AP and IEEE 802.1X/WPA/WPA2/EAP Authenticator” still appeared on the logs and when I tried connecting to the AP, the wifi-connect user interface does not appear.

Another possible solution people recommended in this forum:[https://www.raspberrypi.org/forums/viewtopic.php?t=235145]

was to to edit

/etc/default/hostapd

and set

DAEMON_CONF ="/etc/hostapd/hostapd.conf"

I tried looking for hostapd.conf but it was nowhere to be found, I tried searching for templates but it seems like it hostapd.conf is just a file that helps configure your access point. Im not sure how wifi-connect does it? I’m thinking it had something to do with the Network Manager. Is there a possible workaround for this? Is this is a wifi-connect issue or it does it have something to do with my hardware. For what it’s worth, the whole setup worked on an RPI 3B+.

Any insights would be really great!

Hi @FaitAccompli,

The example you linked to for wifi-connect is a little dated. You may find it easier to follow the example here: https://github.com/balena-io/wifi-connect. Of course, this is the containerized version, but you can probably get more insight into how it works there. Let us know how you make out.

John

Hi @jtonello! The installation instructions just links to the installation script found here [https://github.com/balena-io/wifi-connect]. Right now we’re not trying to use the containerized version, I’m currently trying to check if it’s because of the customized UI we’re using that prevents wifi-connect to serve the website properly. Last time, everything was working correctly. These all started when I tried to export the image I used as .iso so that I can replicate it into other RPI devices.

Thank you so much, I’ll be posting my updates and insights here after some tests.

All the best,
Ray Mart