W10 install issue?

I downloaded and tried to install etcher on my just arrived MS surface… It looked like it went well. no errors.

It is in my app list.

I try to run it but I get “This app cannot run on your PC… Check with the software publisher” blue box from MS.

I also tried to run as “administrator”. Same error

I have it on another PC 1.5.63 and it is fine except only one out of every 4-5 flash attempts actually completes. error always the same… See my other ticket “W10 issue - struck part way though Flash”… console info reported there.



I wonder if it could be processor incompatibility, e.g. ARM vs Intel, 32 vs 64 bits. @AirGar, if you go to System Settings and check “About your PC”, what does it say about “Processor” and also “System type”?

Another suggestion. In the Github releases page for balenaEtcher, I see a couple of executables:

I think by default the Setup one is installed, perhaps you could try the Portable one, just in case.

Both machines have Intel processors and 64bit. Both machines up to date on windows updates.

I ran the “setup” version below and got a “This file does not have an app associated with it for performing this action. Please install the app or, if one is already installed then create an association in the Default Apps Settings page.

Tried the “portable version” and is just goes away… not even visible in the task manager…

No joy!


Hi there,
To my understanding electron apps require to be pushed to the Windows Store in order to work on the MS Surface.
We’ll see what are the implications of doing so and evaluate the possibility of adding a Windows Store package, but for now there’s nothing else we can do unfortunately