Problems installing on Win 10

So Etcher installation seems to run and complete, but the app does not actually install. The install window runs to completion, no errors, progress bar runs thru a couple of times, then the install window just disappears. Checking installed apps confirms etcher did not install. I have tried this many times.

Hi @bill27

Thank you for contacting support! Can you please send us the following information:

  • What is your operating system?
  • What version of Etcher are you trying to install?

Kind regards

Windows 10 64 with all updates. And I’m trying to install the most current 64bit version for Windows. v1.5.113

Hi, is it possible for you to use the portable version instead? Unfortunately we haven’t got control over the installer so it’s harder to reason about.

What does “portable” mean?

Portable in this sense means a single executable file, that does not go through the normal Windows installation process, writes itself into system folders / directories, and registers itself as a “Known” or “Default” application. It is just a single, runnable file that performs the same tasks.

OK, It runs. Will there be an icon for the app? Or do I run the portable file each time.

Well, glad to hear that works at least. I have to wonder if there are permissions issues, protected folders, malware/security software, or other user-profile settings that are not allowing it to complete its installation routine in a normal manner. For convenience, you could simply place the .exe file itself on your Desktop instead of the Downloads folder, and just double-click it to launch it each time. That might be one quick solution, other than chasing down whatever is preventing “proper” installation.

1 Like

Yup. It’s on my desktop. I ran the install as admin FYI.

Interesting, well, then yes I suspect there must be something like an antivirus, Windows Defender, or other security application getting in the way of the proper install. However, if the standalone version placed on your Desktop is a workable solution, it may the easiest/quickest way to simply get to work flashing, ha.

OK, I have tried 3 times now with 2 different SD cards, to burn a file (Astroberry), and all times have failed. I have used a Windows program previously and it worked OK, but the Astroberry community says its best to use Etcher.


This definitely sounds like a permission issue. Do you have antivirus or some other security app running that could be interfering? Also, Chrome Remote Desktop has been known to wreck havoc on systemwide permissions. Are you running any of these?


No for the Chrome remote Desktop. I have Norton 360 running. Prefer not to turn it off, is there a way to allow Etcher in N360?


You may want to check your Windows security settings and, though we’re not N360 experts, this post appears to offer some help: Norton should have the ability to disable certain checks for a few minutes, which might also be an option.


1 Like