Window 10- Etcher 1.5.76 has downloaded i have it in my apps and all that but when i try run it in any way all i get is a buffer on my mouse for 2 seconds and nothing happens

Whenever i try run the program nothing happens

Hi,

Did you try the portable or installed version or both?

i tried both, even went on my other computer. i had it working properly before but when new versions came out it stopped working

Can you try with the latest v1.5.79?
What was the version that previously worked? Can you try that as well?

I have got a similar problem:

Windows 7 Pro, freshly installed, two cores at 2.66 GHz, Etcher 1.5.79 (this is my 1st Etcher, so there is no previous working version)
Only a window with a white background appears, and nothing happens. I tried both portable and installer versions - there is no difference.

Changes of processor usage when Etcher is running:
Four Etcher processes use approx 10% of processor time, svchost.exe dedicated to Etcher uses about 35% of processor time, and procesor time of System is raised from 0 to 15%.

Welcome to the forums Izibia. Have you tried opening Etcher as admin? I was not able to reproduce the issue in Win 10 or Win 7 Pro.

I tried another computer and Etcher works there. But both computers do not differ too much:

The failing one:
ThinkPad x230, 2x2.6 GHz, 4 GB RAM, almost fresh Windows 7 Pro 64-bit, admin account

The working one:
ThinkPad x230, 2x2.9 GHz, 16 GB RAM, Windows 7 Pro 64-bit, admin account

The memory is not an issue, restarted Windows 7 use 900 MB, with (failing) Etcher they use 1.3 GB.
sha3 of Ether’s file is equal on both comps

Oh! In fact also the failing Etcher works!
For example the mouse reacts above the Settings icon area, and a mouse click “opens” Settings probably: at least the mouse changes its shape in the supposed “Settings” window and it does it in same areas like with the working computer (Anonymously report, Eject, Validate write …).

Only the window stays white. So it looks like a display problem.
(Windows theme is equal on both comps)

That’s interesting, I wonder why this is happening. While the blank Etcher is open, can you try opening the devtools and see if anything shows up? You can do that do that by pressing “Control+Shift+I” I believe (I am on a Mac, so couldn’t test it, but I believe that’s the combination).

devtools open a completely black window
again, the mouse responds and I was able to ctrl-C some html code

when I try to drag&drop it shows some text and moves it! So finally I managed to force the window to show something else than the mouse cursor.

it looks devtools just open a html file from AppData - shall I send the content here?


Next text should be placed under the post of tmigone, but the system prevents me to send more than 3 posts in this thread, because I am a "new user"
I will append my next texts to this post again, until I will be allowed to write normally

With my “failing Etcher”, a mouse can get me into the console tab of the devtools window.
But it looks the “command line” is missing and there is no way how to input any command.
I copied the text from the console tab, and it is different from the “working Etcher”. Here it is:

C:\Users\userxy\AppData\Local\Temp\1Y4u8MhluC9ZJW2yUp3ukZcH1d6\resources\app.asar\node_modules\raven-js\dist\raven.js:58 _____ _ _
| | | | |
| |
| |
| | ___ _ __
| || / | ’ \ / _ \ '|
| |
| || (
| | | | / |
_
/ ____|| ||___||

Interested in joining the Etcher team?
Drop us a line at join+etcher@balena.io

Version = 1.5.79, Type = portable
C:\Users\userxy\AppData\Local\Temp\1Y4u8MhluC9ZJW2yUp3ukZcH1d6\resources\app.asar\node_modules\raven-js\dist\raven.js:58 Wed Feb 26 2020 09:46:45 GMT+0100 (Central European Standard Time) Application start ({“packageType”:“portable”,“version”:“1.5.79”,“applicationSessionUuid”:“8dc0430a-390b-4dd5-9378-be72f81c73ae”,“sample”:0.1})
C:\Users\userxy\AppData\Local\Temp\1Y4u8MhluC9ZJW2yUp3ukZcH1d6\resources\app.asar\node_modules\raven-js\dist\raven.js:58 {“stack”:“Error: The specified module could not be found.\r\n\\?\C:\Users\userxy\AppData\Local\Temp\9a035b1c-cd11-4736-81a2-4dad300ff5ee.tmp.node\n at process.func (electron/js2c/asar.js:140:31)\n at process.func [as dlopen] (electron/js2c/asar.js:140:31)\n at Object.Module._extensions…node (internal/modules/cjs/loader.js:922:18)\n at Object.func (electron/js2c/asar.js:140:31)\n at Object.func [as .node] (electron/js2c/asar.js:149:18)\n at Module.load (internal/modules/cjs/loader.js:735:32)\n at Module._load (internal/modules/cjs/loader.js:648:12)\n at Module._load (electron/js2c/asar.js:717:26)\n at Function.Module._load (electron/js2c/asar.js:717:26)\n at Module.require (internal/modules/cjs/loader.js:775:19)\n at require (internal/modules/cjs/helpers.js:68:18)\n at bindings (C:\Users\userxy\AppData\Local\Temp\1Y4u8MhluC9ZJW2yUp3ukZcH1d6\resources\app.asar\node_modules\bindings\bindings.js:112:48)\n at Object. (C:\Users\userxy\AppData\Local\Temp\1Y4u8MhluC9ZJW2yUp3ukZcH1d6\resources\app.asar\node_modules\winusb-driver-generator\index.js:23:37)\n at Object. (C:\Users\userxy\AppData\Local\Temp\1Y4u8MhluC9ZJW2yUp3ukZcH1d6\resources\app.asar\node_modules\winusb-driver-generator\index.js:40:3)\n at Module._compile (internal/modules/cjs/loader.js:880:30)\n at Object.Module._extensions…js (internal/modules/cjs/loader.js:892:10)\n at Module.load (internal/modules/cjs/loader.js:735:32)\n at Module._load (internal/modules/cjs/loader.js:648:12)\n at Module._load (electron/js2c/asar.js:717:26)\n at Function.Module._load (electron/js2c/asar.js:717:26)\n at Module.require (internal/modules/cjs/loader.js:775:19)\n at require (internal/modules/cjs/helpers.js:68:18)\n at C:\Users\userxy\AppData\Local\Temp\1Y4u8MhluC9ZJW2yUp3ukZcH1d6\resources\app.asar\node_modules\etcher-sdk\build\scanner\adapters\driverless.js:55:82”,“message”:“The specified module could not be found.\r\n\\?\C:\Users\userxy\AppData\Local\Temp\9a035b1c-cd11-4736-81a2-4dad300ff5ee.tmp.node”}
console. @ C:\Users\userxy\AppData\Local\Temp\1Y4u8MhluC9ZJW2yUp3ukZcH1d6\resources\app.asar\node_modules\raven-js\dist\raven.js:58
C:\Users\userxy\AppData\Local\Temp\1Y4u8MhluC9ZJW2yUp3ukZcH1d6\resources\app.asar\node_modules\raven-js\dist\raven.js:58 Wed Feb 26 2020 09:47:58 GMT+0100 (Central European Standard Time) Open external link ({“url”:“https://www.balena.io/etcher?ref=etcher_footer",“applicationSessionUuid”:“8dc0430a-390b-4dd5-9378-be72f81c73ae”,"sample”:0.1})
C:\Users\userxy\AppData\Local\Temp\1Y4u8MhluC9ZJW2yUp3ukZcH1d6\resources\app.asar\node_modules\raven-js\dist\raven.js:58 Wed Feb 26 2020 09:48:24 GMT+0100 (Central European Standard Time) Open image selector ({“applicationSessionUuid”:“8dc0430a-390b-4dd5-9378-be72f81c73ae”,“flashingWorkflowUuid”:“b1b17c52-e4b0-43ab-a260-b69cbacab332”,“sample”:0.1})
C:\Users\userxy\AppData\Local\Temp\1Y4u8MhluC9ZJW2yUp3ukZcH1d6\resources\app.asar\node_modules\raven-js\dist\raven.js:58 Wed Feb 26 2020 09:50:50 GMT+0100 (Central European Standard Time) Image selector closed ({“applicationSessionUuid”:“8dc0430a-390b-4dd5-9378-be72f81c73ae”,“flashingWorkflowUuid”:“b1b17c52-e4b0-43ab-a260-b69cbacab332”,“sample”:0.1})


The rest of this message is not important probably.
Tests with my “working Etcher” under Windows: I tried to focus the text cursor into the console. My observations are:

ctrl-shift-I from the main Etcher window works.
ctrl-shift-J does respond neither from the main window nor from devtools
it looks the standard menu shortcut Alt-C is not implemented

I found it! with 9 consecutive I can focus Menu/Elements, then moves the focus to Menu/Console, then moves the text cursor to the console
(but this knowledge doesn’t help with the “failing Etcher”, because the console tab doesn’t include the console input)

Hello, can you see if you manage to navigate to the console tab on the devtools and try to copy anything in there? I realise this is a stretch, but we have not been able to reproduce this behaviour and the only data point we have is one of your installations. On my mac there is a shortcut to the console tab option-command-J so on windows it might be Ctr-Shift-J.

@Izibia take a look at this related issue (also references blank white Etcher with black dev tools): https://github.com/balena-io/etcher/issues/2456

Within that issue there’s a link to a similar one here which relates to settings for Nvidia graphics processors. From what I can tell the x230 was configurable with an Nvidia GPU so that may apply here too. The tl;dr is that you have to force the application to use integrated graphics (rather than accelerated) for this application under these circumstances.

Could you also clarify what graphics cards both laptops have so we can see if there’s a difference there between the working and failing units?

Hope this helps!

@tmigone

my answer is above your post.

@chrisys

Both x230 have Intel HD 4000 graphics card, with an equal driver installed:
driver version 10.18.10.4425, driver date 4.4.2016.

This issue is not a problem for me, I will use another software.
But if the development team considers this issue as an important one, I am ready to help more. I can run some debugging tool if you prepare it, or anything.

Thanks for the extra information. I’ve forwarded the details to the etcher team, so they should be able to take a look and perhaps find more information/the reason for the problems you’re seeing.

Important news:

After two days, “failing Etcher” completed to draw its windows (remember high cpu usage I mentioned above):

step 1
this is the status of devtools/console after two days (in the meantime, I didn’t touch the computer; only thing that hapenned was OS disconnected from the internet, then reconnected):


(it looks the content of the window is equal to the content I blindly copied before, see my text “I copied the text from the console tab” above)

step 2
then I reloaded devtools and I got a different content of the console:


step 3
then I reloaded Etcher and it returned to same “failing” status as described in my first post in this thread. I guess after couple tens of hours the window would be drawn again.

Hi,

Something sounds a bit off here, not sure it’s directly the Etcher code as we have tested and it runs OK here.

I noticed the second screenshot you posted was of Firefox and it’s dev-tools when looking at the Etcher homepage; not of the Etcher process itself like the first. I assume this wasn’t intentional?

LOL. It was my stupid mistake.

Indeed, the 2nd image is the Inspector of Firefox (it is also activated by ctrl-shift-I). I wondered why the devtools changed so much :slight_smile:

So all “step 2” in my previous post is completely invalid.

It happens :grinning:

Something sounds a bit off here, not sure it’s directly the Etcher code as we have tested and it runs OK here.

The first screenshot is full of errors, they are not indicating what is wrong?

…there is some hint to a possible problem, but in testing we don’t see the lack of UI you mentioned.

The logs mention being unable to load the module winusb-driver-generator which is responsible for use with the Compute Module. If you’re missing a driver then it can have this error, but we don’t see the UI issue. Otherwise, no the screenshot doesn’t help in this regard, sorry.

Perhaps a complete removal of the install and a fresh download (confirming the hash too) might yield different results… but at this point I don’t have anything more concrete to provide :frowning: