Validation keeps Failing on SD

I got some problems with my Pinebook so I flashed Armbian onto my SD card an everything worked fine. Armbian didn’t fully solved my problems so I tried to flash the original OS (Manjaro) to my SD but it failed at Validation. So I tried Kali, Debian, another Manjaro build and all of the sudden Armbian again, but everything keeps failing. Also armbian although it used to work without any problems.

Etcher Console doesn’t give me any helpful information.

“Fails at Validation” That means that there is an error in the SD card image. The image written does NOT MATCH the image read from the SD card. ie they are not identical.

So try another SD card, you might have this SD card failing its memory in one spot.

I did, I’ve tried my SDHC and SDXC, both are Sandisk but I can’t tell you the exact model atm, I’m at work. Should I get an “better” brand?

I have heard to NOT USE Sandisk SD cards from a raspberry pi forum. I think Sandisk is a fine product, but must have some problem when used as a boot disk for a device. Look at Samsung SD cards or other Manufactures cards.
Nice back and forth on Etcher.io writing to SD cards. Turns out all the SD cards were fake except the 8 gigabyte SD card that worked fine.

https://www.raspberrypi.org/forums/viewtopic.php?t=237611

Hello @b14ckj4ck ,

So from what I can understand, these are the steps you followed:

  • Flashed Armbian on an SD card (using Etcher?)
  • Tried re-flashing the same SD card with Manjaro and it fails at validation.
  • Tried re-flashing the same SD card with Kali, Debian, etc. They all failed at validation step.

Please correct me if any of the above isn’t correct. If you’re using Windows to flash the SD card, you might be hitting this known issue. Have you tried flashing the same SD card from Linux (or MacOS)?

If the problem is what I linked above, another option would be to try using the SD card even if it can’t be validated.

Let us know how that works.
Cheers,
Nico.

@ntzovanis Half-correct.

The steps are correct (tough I formated between re-flashing) but I’ve tried it with 2 different SD cards.
I have to take a look if i can flash an USB with debian for example to try on linux. It seems like it is the same comparison issue as you mentioned but out of nowhere with an SD that just worked?

I’ll give it a try and let you know as soon as I finished or failed.

-Florian

Update: I just got home and tried my 64GB sandisk sd again, just for fun.

The interesting thing is, even tough it showed me “flash failed” it managed to validate to 100% and the sd card works.

Here’s my console log

Verifying 1 device, 100% at 11.00 MB/s (total 11.00 MB/s) eta in 0s with 0 failed devices
gui.js:42737 Wed Jun 30 2021 19:47:55 GMT+0200 (Mitteleuropäische Sommerzeit) Flash error ({“image”:{“size”:5887754240,“compressedSize”:1257573092,“hasMBR”:true,“path”:“C:\Users\floje\Downloads\Manjaro-ARM-kde-plasma-pbpro-21.06.img.xz”,“partitions”:[{“offset”:32000000,“size”:224000512,“type”:“EBD0A0A2-B9E5-4433-87C0-68B6B72699C7”,“guid”:“3C86890B-8EA1-4368-886C-09377B746452”,“name”:“primary”,“index”:1},{“offset”:256000512,“size”:5631736832,“type”:“0FC63DAF-8483-4772-8E79-3D69D8477DE4”,“guid”:“3D2CE76C-0ACB-464E-8CD5-01694C894836”,“name”:“primary”,“index”:2}],“isCompressed”:true,“name”:“Manjaro-ARM-kde-plasma-pbpro-21.06.img”,“isSizeEstimated”:false,“extension”:“xz”},“drives”:[{“size”:63864569856,“isVirtual”:false,“enumerator”:“USBSTOR”,“logicalBlockSize”:512,“raw”:"\\.\PhysicalDrive3",“error”:null,“isReadOnly”:false,“displayName”:“E:\”,“blockSize”:512,“isSCSI”:false,“isRemovable”:true,“device”:"\\.\PhysicalDrive3",“busVersion”:“2.0”,“isSystem”:false,“busType”:“USB”,“isCard”:false,“isUSB”:true,“devicePath”:null,“mountpoints”:[{“path”:“E:\”}],“description”:“CARDER READER USB Device”,“isUAS”:false,“partitionTableType”:“mbr”}],“driveCount”:1,“uuid”:“e1139c34-e825-4e7a-8583-bb6f349be2d0”,“flashInstanceUuid”:“e1139c34-e825-4e7a-8583-bb6f349be2d0”,“error”:{“name”:“Error”,“message”:“Unmount failed”,“stack”:“Error: Unmount failed”},“sample”:0.1,“applicationSessionUuid”:“25e260da-34e5-4059-99ff-ebe2dc69be01”,“flashingWorkflowUuid”:“b9af5b6e-70f4-4efd-9ee6-0a61f55a7872”})
gui.js:42737 Finish: 5887754240
gui.js:42737 Terminating IPC server
gui.js:42737 Flash results {results: {…}, cancelled: false, skip: false}
gui.js:42737 Wed Jun 30 2021 19:47:56 GMT+0200 (Mitteleuropäische Sommerzeit) Done ({“image”:{“size”:5887754240,“compressedSize”:1257573092,“hasMBR”:true,“path”:“C:\Users\floje\Downloads\Manjaro-ARM-kde-plasma-pbpro-21.06.img.xz”,“partitions”:[{“offset”:32000000,“size”:224000512,“type”:“EBD0A0A2-B9E5-4433-87C0-68B6B72699C7”,“guid”:“3C86890B-8EA1-4368-886C-09377B746452”,“name”:“primary”,“index”:1},{“offset”:256000512,“size”:5631736832,“type”:“0FC63DAF-8483-4772-8E79-3D69D8477DE4”,“guid”:“3D2CE76C-0ACB-464E-8CD5-01694C894836”,“name”:“primary”,“index”:2}],“isCompressed”:true,“name”:“Manjaro-ARM-kde-plasma-pbpro-21.06.img”,“isSizeEstimated”:false,“extension”:“xz”},“drives”:[{“size”:63864569856,“isVirtual”:false,“enumerator”:“USBSTOR”,“logicalBlockSize”:512,“raw”:"\\.\PhysicalDrive3",“error”:null,“isReadOnly”:false,“displayName”:“E:\”,“blockSize”:512,“isSCSI”:false,“isRemovable”:true,“device”:"\\.\PhysicalDrive3",“busVersion”:“2.0”,“isSystem”:false,“busType”:“USB”,“isCard”:false,“isUSB”:true,“devicePath”:null,“mountpoints”:[{“path”:“E:\”}],“description”:“CARDER READER USB Device”,“isUAS”:false,“partitionTableType”:“mbr”}],“driveCount”:1,“uuid”:“e1139c34-e825-4e7a-8583-bb6f349be2d0”,“status”:“finished”,“flashInstanceUuid”:“e1139c34-e825-4e7a-8583-bb6f349be2d0”,“errors”:[{“name”:“Error”,“description”:“CARDER READER USB Device”,“device”:"\\.\PhysicalDrive3"}],“devices”:{“failed”:1,“successful”:0},“bytesWritten”:5887754240,“sourceMetadata”:{“isCompressed”:true,“name”:“Manjaro-ARM-kde-plasma-pbpro-21.06.img”,“size”:5887754240,“compressedSize”:1257573092,“isSizeEstimated”:false},“sample”:0.1,“applicationSessionUuid”:“25e260da-34e5-4059-99ff-ebe2dc69be01”,“flashingWorkflowUuid”:“b9af5b6e-70f4-4efd-9ee6-0a61f55a7872”})
gui.js:42737 Wed Jun 30 2021 19:47:56 GMT+0200 (Mitteleuropäische Sommerzeit) SafeWebview loaded ({“event”:{“id”:72,“url”:“https://www.balena.io/etcher/success-banner/?borderTop=false&darkBackground=true&etcher-version=1.5.116&api-version=2&optOutAnalytics=false",“method”:“GET”,“timestamp”:1625075276269.239,“resourceType”:“mainFrame”,“ip”:“2a05:d014:275:cb02:66df:50b:6e56:a6bf”,“fromCache”:false,“statusLine”:"HTTP/1.1 200”,“statusCode”:200,“responseHeaders”:{“age”:[“5438”],“cache-control”:[“public, max-age=0, must-revalidate”],“content-encoding”:[“br”],“content-length”:[“6087”],“content-type”:[“text/html; charset=UTF-8”],“date”:[“Wed, 30 Jun 2021 16:17:24 GMT”],“etag”:["“849d144883e260c53ef1328ed74b9185-ssl-df”"],“link”:["</webpack-runtime-ce0e6738e6853ac14584.js>; rel=preload; as=script, </styles-c4fa86dfd4ad05097eee.js>; rel=preload; as=script, </framework-42f2600cafd3c0e08aac.js>; rel=preload; as=script, </50c25a04-efe577ee14c9c53bed03.js>; rel=preload; as=script, </73ad3401-e112b47ad7a992b91ac8.js>; rel=preload; as=script, </532a2f07-16f3498dd087ee7288d4.js>; rel=preload; as=script, </app-aac6a81a79937d1ac2bd.js>; rel=preload; as=script, </c943faba-f859f80ceb7f4f7eab31.js>; rel=preload; as=script, </af13d906-36fdbc23fc7dd2f2b2e7.js>; rel=preload; as=script, </ec1189df-4ae9e03f4545d4f1d61b.js>; rel=preload; as=script, </a9a7754c-29508ff4045f1f93a5f6.js>; rel=preload; as=script, </commons-8fcc2f56d20b76e33299.js>; rel=preload; as=script, </edad6859a763f5239c0343c48608d154b87713d6-282649cf8ac0a71046b8.js>; rel=preload; as=script, </component—src-pages-etcher-success-banner-js-c81df2b0c3894e1f37af.js>; rel=preload; as=script, </page-data/app-data.json>; rel=preload; as=fetch; crossorigin, </page-data/etcher/success-banner/page-data.json>; rel=preload; as=fetch; crossorigin"],“referrer-policy”:[“strict-origin-when-cross-origin”],“server”:[“Netlify”],“status”:[“200”],“strict-transport-security”:[“max-age=31536000”],“vary”:[“Accept-Encoding”],“x-content-type-options”:[“nosniff”],“x-frame-options”:[“DENY”],“x-nf-request-id”:[“01F9F0HWCZ2WTTK2K2MQV2HPYN”],“x-xss-protection”:[“1; mode=block”]},“referrer”:"",“error”:“net::OK”},“sample”:0.1,“applicationSessionUuid”:“25e260da-34e5-4059-99ff-ebe2dc69be01”,“flashingWorkflowUuid”:“b9af5b6e-70f4-4efd-9ee6-0a61f55a7872”})

Hi,

Thanks for getting back and attaching logs from the last run. I see the failure is with un-mounting the device after successful flash. Do you know if the device was accessed during the flash or right after?

Cheers,
N

Sorry for my delayed answer.

No, i don’t think so.

It seems like what may be happening is that something in the OS is grabbing the SD card before we’re done with it. Other than logging an issue, I’m not sure what more can be done. I’ll ping our Etcher maintainers and see if they have anything to add.

From the logs, it seems you run Etcher on Windows. Do you have any anti-virus software installed? Those tend to grab new disks as soon as they appear to scan them at the earliest possible moment, which unfortunately often interferes with software like Etcher

Hello.

I’m new to this forum and the flasher.

I’m running into issues burning a TWUL persistent image onto a SanDisk 32gb thumb drive. It keeps failing at validation sequence.

Are these even reputable drives to use? Should I go with a different media/storage size or manufacturer altogether?

Please advise and thanks in advance for your help.

Hi @obie1kin00b13,

Don’t think the thumb drive should be an issue. Is the drive bootable after you finish the flash (with validation failing)?

Also, what OS are you running this from? And were you able to try any other drive or SD card and see the same issue?

Regards,
N

Hi, Nitish.

Thanks for responding so quickly.

I’m actually trying to burn a copy of FWUL persistent in order to flash custom recovery and root.

It needs to have these prerequisites to carrier unlock an LG phone (T-Mobile V30).:persevere:

Tried it on 2 thumb drives (16 and 32gb); both were damaged. Ordered a 3rd one, but haven’t tried it yet.

Didn’t pull a console log of the last fail and should’ve.:expressionless: