flashing OS for ARM-devices to microSD card

Some month ago I started using etcher to flash a raspi-image and some other. One day the cards contained instead boot + rootfs partitions only the look like on a “normal” bootable cd. Sometimes it worked fine again, but more and more not. This is the time where I’m unable to create a bootable mSD.
Have I done wrong something?

Hi Will, that sounds like the SD card is failing and it gets corrupted. Depending on what SD card you are using, this is expected, as each card has a certain expected lifetime expectancy. If you do heavy writing on the cards, the lifespan can get much shorter. Did you see this behavior only on one specific SD card, or on multiple ones?

I bought yesterday 2 mSDHC Class 10 8GB Intenso. On both I had the same problem.
Samsung and Sandisk cards worked better till they failed.

What image are you trying to flash? Do you get any errors while flashing in etcher? For errors that might not be shown, you can toggle the devtools by going to View -> Show developer tools and you can check if there were any errors logged there. Also, please provide the Etcher version you are running. Any other information would be helpful in order to see if this is a problem with Etcher, the image, or with the SD cards.

  • Lastly NextCloudPi_OdroidHC2_01-08-20.img
  • Errors were never shown.
  • Don’t know to do this.
  • Version 1.5.71

I tried to flash to a very new sd card16 GB Sandisk - same issue!!

It must depend in the image NextCloudPi_OdroidHC2_01-08-20.img
Raspbian buster was created well.

Hi there @alwi,

As mentioned in https://github.com/balena-io/etcher/blob/master/SUPPORT.md#forums, you can access the DevTools via a keyboard shortcut, either Ctrl+Shift+I or Cmd+Alt+I depending on your platform. Please try again and paste any output you see in that panel, along with the platform you are using.

Thank you!

Her is the end of the logfile, result no boot-partition:
Flash results
{results: {…}, cancelled: false}
/opt/balenaEtcher/re…js/dist/raven.js:58 Fri Jan 24 2020 19:49:14 GMT+0100 (Mitteleuropäische Normalzeit) Done ({“errors”:,“devices”:{“failed”:0,“successful”:1},“status”:“started”,“image”:"/home/xx/Downloads/Odroid/NextCloudPi_OdroidHC2_01-08-20.img",“drives”:[{“size”:15931539456,“isVirtual”:false,“enumerator”:“lsblk:json”,“logicalBlockSize”:512,“raw”:"/dev/mmcblk0",“error”:null,“isReadOnly”:false,“displayName”:"/dev/mmcblk0",“blockSize”:512,“isSCSI”:null,“isRemovable”:true,“device”:"/dev/mmcblk0",“busVersion”:null,“isSystem”:false,“busType”:“UNKNOWN”,“isCard”:null,“isUSB”:null,“devicePath”:"/dev/disk/by-path/pci-0000:03:00.0-platform-rtsx_pci_sdmmc.0",“mountpoints”:,“description”:"(boot, rootfs)",“isUAS”:null}],“driveCount”:1,“uuid”:“3b899103-820d-42ef-8b09-cfbedb7ff904”,“flashInstanceUuid”:“3b899103-820d-42ef-8b09-cfbedb7ff904”,“unmountOnSuccess”:true,“validateWriteOnSuccess”:true,“trim”:false,“applicationSessionUuid”:“12754122-fd82-4f87-9431-dfbb359cf07b”,“flashingWorkflowUuid”:“cf0ea9d1-d2ed-47a0-9b07-7aa4fea2cc90”,“sample”:0.1})
/opt/balenaEtcher/re…js/dist/raven.js:58 Terminating IPC server
/opt/balenaEtcher/re…js/dist/raven.js:58 Fri Jan 24 2020 19:49:14 GMT+0100 (Mitteleuropäische Normalzeit) Navigate ({“to”:“success”,“from”:“main”,“applicationSessionUuid”:“12754122-fd82-4f87-9431-dfbb359cf07b”,“sample”:0.1})
/opt/balenaEtcher/re…js/dist/raven.js:58 [withTheme] You are not using a ThemeProvider nor passing a theme prop or a theme in defaultProps in component class “Component”

Hi @alwi

Thanks for the logs that you have sent. On what platform are you running Etcher? (e.g. Windows10/Ubuntu18, etc.)

Kind regards
Alida

I use Manjaro-Linux and Arco-Linux always in the latest version.

Just thought it might be useful - I found this on the NextCloud forums… https://help.nextcloud.com/t/if-flashing-the-sd-doesnt-create-boot-rootfs/69098

I tried to flash NextCloudPi_OdroidHC2_01-08-20.img to different mSDHC10, new ones or yet used. The result in every case - etcher, susestudiowriter, dd, usb-creator - there is no extra-partition for boot. So its impossible to start the odroid HC.

Looks like it might be an issue with their image?

That’s my own thread. I try to reach the developer “nachoparker.”
I need a statement how the boot process works on Odroid HC1.
Either the file or the hardware is faulty.
Because the of flashing armbian works ok with Etcher, I urgently await the developer’s statement.

Can you try to flash another Odroid HC1 image that is not NextCloud and see if that consistently works fine? If so, it would help us pin point the issue the NextCloud’s image

In the meantime I was on other forums: Odroid and Armbian. I could not find a solution.
For me as an outsider it is difficult to determine where the fault lies.
So far I have already exchanged the hardware without success.
I have flashed OVM and Armbian in 3 variations on the SD card. I verified the image files and checked the checksums. Could I exclude the errors in the images?
Can the same hardware errors occur twice? Is my installation of Belena-Etcher faulty?
With the command dd I found the following peculiarity:

sudo dd if=Armbian_20.02.0-rc1_Odroidxu4_stretch_legacy_4.14.165.img  of=/dev/mmcblk0 bs=1M
[sudo] Passwort für xy: 
1076+0 Datensätze ein
1076+0 Datensätze aus
1128267776 bytes (1,1 GB, 1,1 GiB) copied, 0,519291 s, 2,2 GB/s

This means nothing was copied. This I had never before.

In such a constellation I have heard for 30 years that the buck always lies with the others, including me.

If you have tried flashing this image with multiple image writing tools and they all encountered errors, that would highlight that the issue is likely not with the image writing tools you are using. My recommendation for debugging this issue is to methodically replace each step until you find something that works. For example, have you tried using a different card reader?