USB RAW - keeps disconnecting

I flashed Debian Live iso on USB I bought hours before that. It worked, but I didn’t want to keep Debian so I immediately rebooted. In Win 10 Pro I tried to format, but ‘Windows was unable to complete format’ pops up.
In cmd(admin), I tried to clean with diskpart, but it would give me error: Access is denied. USB disappears from both File and Disk Management. DM also couldn’t format.
I flash another USB with Gparted.iso and format USB to FAT32. Now it shows in Win, but keeps disappearing. In format in fdisk. Than I manage to format in Windows and it appears to be fine. But doing anything with it (eg. writing files) disconnects it and it shows it as RAW, Healthy. Sometimes reverts to Unallocated.
Easeus showed no bad sectors.

So most of the solutions I found don’t work:

  1. Diskpart and clean
  2. Format in File / Disk Management
  3. Format in gdisk or fdisk
  4. Using Easeus, AOMEI

It sounds like a hardware problem. Most likely, either your USB stick or USB port is faulty. I’d test the stick with other ports/computers to help isolate the problem.