Updating... forever?


This is my first time installing balenasound. I’m using a RASPBERRY PI 3 MODEL B+ (64 bit). Everything seems to be OK but it has now been “updating” for more than an hour, is that normal?

I’m using balenaOS 2.47.0+rev1 (64 bit) in development mode.

Here is the lines in the log that seem to be coming over and over again:

16.11.20 11:17:56 (+0100) Downloading image ‘registry2.balena-cloud.com/v2/bd067b52e1220ac8693b2d3175ee4ad8@sha256:1b4d6edf2f138b3ada3ac293f44415dab3f6c4f7349c6b72a9bf2c1097e0df9c

Could you please help? Shall I wait or is it struggling to install the services?


Hello, thank you for contacting on the forums. Did it work finally?

Nope, I tried to re-build the SD, also to do it through Ethernet. Same behaviour.

Just granted support access to c417c61e9d76b77d4e8a1ba1dc85194b in case you might want to take a look.


It looks like your SD is not working properly as we detect on the Health diagnostics that there is a Slow disk write detected. Could you please try another SD card?

Yep, just changed the SD and seems to be progressing adequately.

The former card seems to be working fine in other environments, do you know why it does not here?


Well, now the services are running but I have no sound through the jack?

Hi there, here is something you could try (taken from here: https://github.com/balena-io/balena-supervisor/issues/1245) -

  • go to the dashboard, to the device configuration tab on the right hand side, and look for ‘Define DT overlays’. Change "vc4-kms-v3d" to "vc4-kms-v3d,audio=off","" and then reboot

  • if this still doesn’t work, then you can try using the 32-bit rather than 64-bit OS.

Hasn’t worked, will try 32-bit. Thanks.

I’ m not able to add the device with the 32-bit version. Never appears in the dashboard.

@wtb please can you give us an idea of the steps you have tried? If the device doesn’t appear in the dashboard it’s likely that it simply doesn’t have a network connection.

Same steps but selecting Raspberry 3 instead of Raspberry 3 with 64 bits. Tried with wired connection, nothing happens.

OK, here are some troubleshooting steps you can take a look at: https://www.balena.io/docs/faq/troubleshooting/troubleshooting/

It may also be useful to plug a monitor into the device and check the output on screen. If you can give us more detail on what’s going wrong we may be able to help more.