Trouble flashing from file

Hello everyone,

I’m a noob using Etcher for the first time, and I’ve run into a roadblock. I’m using balenaEtcher 1.5.120 on a refurbished 2013 MacBook Pro running macOS Catalina version 10.15.6.
I’m attempting to flash an ISO image of Parrot OS Home Edition version 4.11.2 onto a USB drive. When I open balenaEtcher and choose “Flash from File,” however, I am unable to select the ISO file that I torrented. The file name is visible in my downloads folder, but it is unclickable/unresponsive.

As far as I’m aware, my laptop meets/exceeds the recommended hardware requirements to run Parrot Home OS, so if anyone can enlighten me as to why Etcher won’t allow me to select the ISO file, I’d really appreciate it.

Hi Kyle, welcome to the Forums. That file should be fine to flash. I just downloaded one myself, opened Etcher, and can choose it from the file selector. Etcher recognized mine ok:

So, the first thing I would check is, the MD5 hash to make sure you have the full download. Instead of using the Torrent version, try downloading a direct copy of the file from one of their mirrors.

You can then check the hash file versus what they document here:

I tried what you suggested, and it worked like a charm. Thanks so much for your help.