Transfer Application Ownership fails


I am trying to transfer an application that I own to another user, and I have followed the guidelines here. I am able to get to the final steps of the process (typing in the application name to confirm the transfer after choosing my target user) and I get a red banner that pops up at the top of the screen saying “Request error: Must specify username”. I have confirmed that the transfer does not complete after this. I also confirmed that logging out and back in does not allow me to transfer the application either.

Can someone in support look into this? Thanks!


Just to check, are you trying to transfer using the users username or their email address?

Best regards, Heds

The other user’s username shows up when I click the “Transfer Ownership” button, not their email address

Double post - sorry.

Just to be clear, I have followed all of the directions laid out in the docs and the video, and everything goes fine until the very last step when I get that error. We both have an application named the same thing, I am added as a dev user on the target user’s application, and his username shows up when I go to transfer the app. After I type in the name of the application to confirm, I get the error. I don’t have a lot of other knobs to turn here, so I am suspecting it is an issue with your systems.

I tried the process again today in case it was some sort of cache issue, and I get the same error.

Hey there, I will have a look at it now and get back to you.

Hi @dank,
Does the application that you are trying to transfer have any additional members?
If that’s the case, then this is a known issue for which we are a fix which we are planning to get released soon.
In the mean time, if you are getting blocked by this, a workaround for the issue would be to

  • remove the members from the application that is going to be transferred
  • transfer the application to the other user
  • have the receiver add the application members back (if they still need access).

Kind regards,

That did it! Thanks for the assistance!

Hi again,
We have just released a new version of our backend which includes a fix for this.
Give us a note if you still face any issues while transferring applications that have extra application members.

Kind regards,