To Boot or not to boot..that is the question.

So Im hoping (as im no expert) someone may be able to explain why i can boot my usb created with Balena on an old laptop and one old PC (When I say old im talking very old socket 775 ) but not on another socket 775. Im trying to install proxmox which is a hypervisor to try it out. They advice 2 different usb writers, one being Balena, which they say works out of the box.
I created my bootable usb from an iso (hybrid iso) in Balena. Through it on an old Dx2400 775 motherboard and it booted up no problem. Tried it on my old dusty laptop that was shoved away in a cupboardā€¦booted fine. Now I wanted to experiment with gpu passthrough but needed a board with q35 chipset. So i grabbed an old Intel DQ35JOE LGA775 to try, but it wont boot from my USB. Anyone have any ideas?
Bios is set as usb legacy, Boot order USB first, Uefi disabled or enabled (tried both) no boot. Just wont seem to read the usb stick even though its listed and i can select it.

Hi, sorry for the delay in coming back to you. What device type are you using? The recommended one for PC systems is the Generic x86_64 image.