USB boot drive not bootable in bios

So I was trying to create a USB stick that I can use to boot Linux on my laptop, and ended up using Etcher. I “successfully” flashed the newest version of Pop_OS onto the stick, and restarted my computer to try and boot from my USB stick. However, when going through the BIOS, I could not find the USB stick anywhere. Furthermore, the USB stick is no longer visible in the windows 10 file explorer, though from what I can tell that is part and parcel of using Etcher.

Am I missing something that I need to do to be able to boot from the USB stick? Or if the USB stick is borked, is there a way to recover it so I can at least use it for other things? Sorry if the answer is simple, as I am new to all this.

The version of Pop_Os I used was 19.10 Nvidia, and the USB stick I am using is the SanDisk SDCZ48-128G-U46. The laptop I am trying to boot on is an ASUS TUF FX504 laptop.

Unfortunately, Windows get confused sometimes with Linux partitions. Take a look at: https://github.com/balena-io/etcher/blob/master/docs/USER-DOCUMENTATION.md#recovering-broken-drives.

As for your BIOS, it’s hard to know what might be wrong. This could be due to a corrupted Pop_OS image, something wrong with the flashing process, a bad USB stick or USB port. I’d suggest first redownloading the image and checking its checksum before reflashing the USB.

1 Like

I cleaned the drive, and now its visible, but its asking for me to insert a disc when I try to open it.
Also, how do I go about checking the checksum? I googled it and from what I can tell its some sort of way to verify that its the proper iso and not a tampered one, but nothing was that helpful on how to actually go about it.

There are several things that can go wrong when trying to boot an OS from USB:

  • Issues with the image legacy / EFI boot
  • Your PC might just not be set up to boot from USB

Have you successfully booted your PC from USB before ? If not it might not be set up to boot from USB at all. Otherwise there might be a key (typically hardware dependent) you need to hit at boot time to select boot options. When you say However, when going through the BIOS, I could not find the USB stick anywhere was that in bios settings ?

To check checksums on your downloaded image I found this article ( https://www.lifewire.com/validate-md5-checksum-file-4037391 ) My google search was check image md5on windows - you will find plenty more instructions…

I assume I was in the bios settings, considering I have to press F2 when the laptop boots up to get to it. I haven’t set it up to boot from a USB drive before, so I think its not properly set up. However, when I tried to do this using YUMI, it recognised a partition of the USB drive, but when I tried to boot it it always reverted back to windows. If its not properly set up, how do I go about setting it up to boot from a USB drive?

I checked the SHA256 sum with the one provided on the website, and it matches, so I don’t think there is a problem with the iso.

Hey @TotallyPorff, honestly this issue goes beyond what we offer as part of balena or Etcher :sweat_smile:

Seems like Etcher has done its job fine and you are having difficulty to boot from a USB stick. I’d suggest searching online to figure out how one could boot your type of laptop with a USB stick. I found these solutions online for Asus laptops that might help:


Hope you manage to get it working.