Intel Generic x86_64 on Dell 7220 PC


Our application ships on Dell 7212 PC running the Generic x86_64 image. This image installs fine on this device. The Dell 7212 has been replaced by the 7220 recently so we have to support that going forward. The issue is the Generic x86_64 image does not boot on this device, we tried a few other Intel types but none boots. The image is selectable from the bios prompt but freezes immediately after selected, before even the splash screen is loaded. Booting a Ubuntu 19.04 image on the same machine works fine.

If I can get some trace logs from the tty that would help. What are the debug options I have to try and chase this down ?


Hi there, is the bios on the new device particularly different to the older one? Especially in the disk boot section (e.g. on Intel NUCs disabling secure boot feature was/is required for the balena images to boot).

Please try to update the device firmware if not already the latest. Also resetting the bios to factory defaults may be a good starting point.

Yes, the bios does differ a bit. To get BalenaOS installed on the previous generation 7212 I have to set:

  • Secure Boot/Secure Boot Enable/Disabled
  • System Configuration/SATA Operation/AHCI

This is set in the 7220 bios as well. The 7220 bios is at 1.5.0 the latest version. I spent quite some time poking around the bios flicking relevant looking things on and off to no avail.

As I said I did manage to boot Ubuntu 19.04 as a sanity check of a flash drive, which worked fine on the 7220.

Hey :wave: ,

It would be very helpful if you could get any trace logs from tty. Also, if you could re-flash a usb stick and then try to boot from it, then take a photo of the logs that are produced during the first boot. With these, we might be able to trace the problem down to some specific bios setting.

We will get to the bottom of this!


There are no trace logs on the screen at all, just a ‘-’ character, not even a splash screen. I select the USB boot device from the bios, the screen drops to ‘-’ immediately. This device has no external tty so a USB->tty device won’t make much sense I think as that would imply a booting kernel - I don’t think it gets that far.

Are there any log options I can set on the flash drive to increase log verbosity assuming the kernel does boot and a working screen driver is loaded ?

Thanks for the clarification

Just to be certain, can you try again with another USB stick and if that doesn’t work, please try using the NUC image.

Yea we have tried multiple USB drives and multiple Intel image types:

  • Intel Generic
  • NUC
  • MS Surface

All the same behavior

The Dell 1.5.0 bios on this tablet does not have any options for ‘legacy boot’. I suspect it only supports UEFI Class 3 booting. Does the BalenaOS image support this setup ?

Did you have any success with grabbing some logs - any logs? I’m relaying the boot question to the device team, thanks for trying all of those setups

There are no logs no. Seems very much like that the freeze happens before the kernel even starts to load.

Ah that’s good to know. I will let you know what the team says

Hello, I know secure-boot was mentioned previously, but could you please confirm that it is disabled in the BIOS? (this must be disabled for the images to boot).

Yes secure boot is disabled as mentioned previously. If its not disabled the Dell ‘recovery’ system is activated.

One other thing to check (I can’t see it mentioned in this thread) - are you able to control sleep-type in the bios power settings? If so, it should be set to Legacy S3 standby or similar.

I can’t find any settings to that effect no. I did try and disable any power management options available as well. No positive effect with any of those.

Hey there! Are you able to boot any other GNU/Linux distribution on that same computer?

Yes, as mentioned before, Ubuntu 19.04 ran of the Ubuntu USB stick no problem. In the mean time I installed Ubuntu 20.04 on the device and that went without a hitch.

Ubuntu running on the 7220

Selecting BalenaOS to install

No Balena for you

Hi, can you send over the complete bootlog of either of them?

Here’s the Ubuntu 20.04 boot log, and some others you may find usefull

boot.log (413.5 KB)


dmesg.log (85.0 KB)


dmidecode.log (36.9 KB)