Strangeness updating and then connecting RPIv1



I’m working with a Raspberry Pi, getting to grips with:

  • building the base image with resin-raspberrypi and the new barys tool
  • overlaying a Qt5 based Yocto Jethro image and starting the UI up

The resin build seems to work OK for me excepting that I have to rename the kernel image in the FAT boot partition from Image-raspberrypi.bin -> kernel.img for some reason

Then I grab the config.json from a production image (I wasn’t able to connect to staging for some reason) and initially saw my device connecting, configuring, and was able to push a dockerfile to the app repo which resulted in image downloads

However this morning as I pushed a new commit to the repo with minor changes to the dockerfile it didn’t update the device. I created another app and moved the device to that app but that didn’t help. I then reflashed the device with the original resin image (with kernel.img change and the config.json) and now it seems not to be able to connect

I see in the builld log there seem to be a lot of builds in a running state. I’m not sure if that’s relevant?




Hi Alex,

Let me start with the running state of the builds, this is a known issue in the UI and it should not affect you in any real way.

As for your OS this is a weird case, because your hostOS is modified, but let me understand a bit more what do you mean by overlaying a Qt5 image? Have you added a qt layer to our build? Could I have a look at it? Maybe it has bad interaction with our current build.

Now, for the specific device is it still powered and connected? I can have a look at it to try and figure out what happened from that end.

Best regards,


Hi Theodor,

I’ve just switched the RPIv1 back on and it’s booted to “Booted - check your dashboard”

I haven’t modified the resin build itself, instead creating a new image I’ve pushed to Docker hub

This was working quite nicely earlier on.

App is TestRpi

The Qt5 enabled image is up at

Docker file is along the lines of

# Test Yocto Mono hello world docker image
FROM dynamicdevices/qt5-x11-image-raspberrypi:20160407171142
MAINTAINER Alex J Lennon <>

# Seem to have to create /volatile/log ?
CMD ["mkdir /var/volatile/log"]

# Start X11
CMD ["/etc/init.d/xserver-nodm start"]

# Test
CMD ["echo starting"]

# Loop so we can access terminal
CMD ["/"]




Could you check if the rpi has network access?


I have OK (off), PWR (on), FDX (on), LNK (flashing with network activity), 10M (on)


For another quick test I took the RJ45 connector out of the RPIv1 and attached it to my laptop, at the same time turning off Wifi. I had internet access. Removing the RJ45 from the laptop I no longer had internet access.

(A slightly different question is that I’d prefer to have a staging build so I had shell access to the device under development but when I tried this originally I was getting errors logged from the supervisor relating to attempts to make a connection. This was with the downloaded image. This is why I went over to production)


The reason behind not having access to the device is probably due to the switch between apps. When you re-flashed the device? What image did you use? (download from dashboard or your custom image)


To get staging configured images use our staging server . This is a separate server then our usual resin that has the bleeding edge version of our code, so we do not provide any guarantees about these images, but they are great for testing/dev work.


When I reflashed the device I used my generated image with the config.json from the original TestRpi app OS image download

Yes, I was using originally but for some reason it was erroring connecting. I figured that it might be in flux so went over to production


Ok Alex,
I am confirming this now it looks like the master point of meta-resin has quite an issue with the way it handles dns due to a new change to our base image. We have on-going internal discussion now, chat with us live here I will update this post on this issue as we have a resolution.
Best regards,