SOUND_DISABLE_BLUETOOTH set, but bluetooth still visible, connectable, and working?

I have two devices, raspberry pi 3 b+ and a r-pi 3b,
One is set as SOUND_MODE, MULTI_ROOM_CLIENT, the other is default.

As I wont be needing or using Bluetooth, I set SOUND_DISABLE_BLUETOOTH in both devices. I’m also doing this to avoid any Bluetooth/Wi-Fi interference.

However, on my phones, they still are visible and if you connect to the pi that is the master, balenasound plays/streams the audio.

if you connect to the pi set as client, it says connection unsuccessful on the phone.

In the dashboard next to the Bluetooth service, it is listed as exited.

I also tried setting the variable as a fleet variable instead and had the same experience.

Am I missing or misunderstanding something?